YT02-简单数学课后题-1003 Heritage from father -(5.31日-烟台大学ACM预备队解题报告)

79 篇文章 0 订阅

Heritage from father

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131070/65535K (Java/Other)
Total Submission(s) : 95   Accepted Submission(s) : 31
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Famous Harry Potter,who seemd to be a normal and poor boy,is actually a wizard.Everything changed when he had his birthday of ten years old.A huge man called 'Hagrid' found Harry and lead him to a new world full of magic power. 
If you've read this story,you probably know that Harry's parents had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the bank hold up by Goblins). And they stepped into the room which stored the fortune from his father.Harry was astonishing ,coz there were piles of gold coins. 
The way of packing these coins by Goblins was really special.Only one coin was on the top,and three coins consisted an triangle were on the next lower layer.The third layer has six coins which were also consisted an triangle,and so on.On the ith layer there was an triangle have i coins each edge(totally i*(i+1)/2).The whole heap seemed just like a pyramid.Goblin still knew the total num of the layers,so it's up you to help Harry to figure out the sum of all the coins.

Input

The input will consist of some cases,each case takes a line with only one integer N(0<N<2^31).It ends with a single 0.

Output

对于每个输入的N,输出一行,采用科学记数法来计算金币的总数(保留三位有效数字)

Sample Input

1
3
0

Sample Output

1.00E0
1.00E1

Hint

Hint
when N=1 ,There is 1 gold coins. 
when N=3 ,There is 1+3+6=10 gold coins.

Source

Gardon-DYGG Contest 1



144-2- 赵利利

只有一个硬币上,三个硬币是由一个三角形的下一层。第三层有六个硬币也由一个三角形,等等。第i个层上有一个三角形,我每个硬币边缘(i*(i + 1)/ 2)。整个堆看起来就像一个金字塔


•解题思路:
–根据题目描述,找出规律。题目中已经给出每一层金币个数的公式,n=i*(i+1)/2;
•Sum=sum(N-1)+n;

可以用递归,也可以用循环,但都会超时。

–于是,还有一个公式

Sum=N*(N+1)*(N+2)/6

注意:最后科学计数法输出

Ejó10^j     

jósum的位数减一


//循环
    超时


#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;
int main()
{
    long n,i;
    while(cin>>n&&n!=0)
    {
        double sum=0;
        
            for(i=0;i<=n;i++)
                {
                    sum+=i*(i+1)/2;
                }
    int j=(int)log10(sum);
    sum=sum/pow(10,j);
        cout<<setiosflags(ios::fixed)<<setprecision(2)<<sum<<"E"<<j<<endl;
    }
    return 0;
}

//AC代码

#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;
int main()
{
    long n;
    while(cin>>n&&n!=0&&n!=EOF)
    {
        
    double sum=(n+1)/6.0;
    sum=sum*(n+2);
    sum=sum*n;
    int j=(int)log10(sum); //求sum几位数   共j+1位数
    sum=sum/pow(10,j);	//sum用科学计数法来表示
        cout<<setiosflags(ios::fixed)<<setprecision(2)<<sum<<"E"<<j<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值