YT02-简单数学课后题-1004 The Last Practice -(5.31日-烟台大学ACM预备队解题报告)

79 篇文章 0 订阅

The Last Practice

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 100   Accepted Submission(s) : 29
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input

Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60
12
-1

Sample Output

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1
Hint
60=2^2*3^1*5^1

Author

lcy

Source

杭电ACM集训队训练赛(IV)



143-2 李军
#include <stdio.h>
int main()
{
    int n, c, count, i;
    c = 1;
    while(~scanf("%d", &n) && n > 0)
    {
        count = 0;
        if(c != 1)
            printf("\n");
        printf("Case %d.\n", c++);
        if (n%2 == 0)
        {
            printf("2 ");
            while(n%2 == 0)
            {
                count++;
                n /= 2;
            }
            printf("%d ", count);
        }
for (i = 3; i <= n; i += 2)
        {
            count = 0;
            if(n%i == 0)
            {
                printf("%d ", i);
                while(n%i == 0)
                {
                    count++;
                    n /= i;
                }
                printf("%d ", count);

            }
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值