POJ-1782 Run Length Encoding-相同字符个数

Run Length Encoding
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4331 Accepted: 1406

Description

Your task is to write a program that performs a simple form of run-length encoding, as described by the rules below.

Any sequence of between 2 to 9 identical characters is encoded by two characters. The first character is the length of the sequence, represented by one of the characters 2 through 9. The second character is the value of the repeated character. A sequence of more than 9 identical characters is dealt with by first encoding 9 characters, then the remaining ones.

Any sequence of characters that does not contain consecutive repetitions of any characters is represented by a 1 character followed by the sequence of characters, terminated with another 1. If a 1 appears as part of the sequence, it is escaped with a 1, thus two 1 characters are output.

Input

The input consists of letters (both upper- and lower-case), digits, spaces, and punctuation. Every line is terminated with a newline character and no other characters appear in the input.

Output

Each line in the input is encoded separately as described above. The newline at the end of each line is not encoded, but is passed directly to the output.

Sample Input

AAAAAABCCCC
12344

Sample Output

6A1B14C
11123124

Source

Ulm Local 2004
#include<stdio.h>
#include<string.h>
int main()//空格也算字符
{
    char str[200];
    int i,j,cnt;
    while(gets(str))
    {
        if (!str[0])
        {
            putchar(10);
            continue;
        }
        cnt=1;
        for(i=0; str[i]; i++)
        {
            if (str[i] == str[i+1])
            {
                for ( j = i ; str[i] == str[i+1] && (i-j) < 8 ; i++ );
                printf("%d%c", i-j+1, str[i]);
            }
            else
            {
                printf("1");
                for(j=i; str[j]; j++)
                {
                    if(str[j]!=str[j+1])
                    {
                        if(str[j]=='1')
                            printf("1");
                        printf("%c",str[j]);
                    }
                    else
                        break;
                }
                printf("1");
                i=j-1;
            }
        }
        printf("\n");
        memset(str, 0, sizeof(str));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值