POJ 3264-Balanced Lineup详解(线段树区间求值)

Balanced Lineup

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 43147 Accepted: 20265
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

题意是说:
给定一些坐标点和值,求区间内最大最小值的差。
给定Q (1 ≤ Q ≤ 200,000)个数A1,A2 … AQ,多次求任一区间Ai– Aj中最大数和最小数的差。

只是刚学习线段树,想说说建树和插入。
以题目中的Input为例:

建树。
是分割区间,递归建。
分割区间是指,将所有的数的个数不断均分划成两颗子树,直到L=R。
如图:


插入:



这样就分完了:

分别是
root,L,R,Min,Max



代码fromhttp://acm.pku.edu.cn/summerschool/pku_acm_train.htm

#include <iostream>
#include <cstdio>
using namespace std;
const int INF = 0xffffff0;
int minV = INF;
int maxV = -INF;
struct Node //不要左右子节点指针的做法
{
    int L, R;
    int minV,maxV;
    int Mid()
    {
        return (L+R)/2;
    }
};
Node tree[800010]; //4倍叶子节点的数量就够
void BuildTree(int root, int L, int R) //0 1 6
{
    tree[root].L = L;
    tree[root].R = R;
    tree[root].minV = INF;
    tree[root].maxV = - INF;
    if( L != R )
    {
        BuildTree(2*root+1,L,(L+R)/2);
        BuildTree(2*root+2,(L+R)/2 + 1, R);
    }
}
void Insert(int root, int i,int v)//0 i v
//将第i个数,其值为v,插入线段树
{
    if( tree[root].L == tree[root].R )//单值节点
    {
//成立则亦有 tree[root].R == i
        tree[root].minV = tree[root].maxV = v;
        return;
    }
    tree[root].minV = min(tree[root].minV,v);
    tree[root].maxV = max(tree[root].maxV,v);
    if( i <= tree[root].Mid() )
        Insert(2*root+1,i,v);
    else
        Insert(2*root+2,i,v);
}
void Query(int root,int s,int e)
//查询区间[s,e]中的最小值和最大值,如果更优就记在全局变量里
{
    if( tree[root].minV >= minV && tree[root].maxV <= maxV )
        return;
    if( tree[root].L == s && tree[root].R == e )
    {
        minV = min(minV,tree[root].minV);
        maxV = max(maxV,tree[root].maxV);
        return ;
    }
    if( e <= tree[root].Mid())
        Query(2*root+1,s,e);
    else if( s > tree[root].Mid() )
        Query(2*root+2,s,e);
    else
    {
        Query(2*root+1,s,tree[root].Mid());
        Query(2*root+2,tree[root].Mid()+1,e);
    }
}
int main()
{
    int n,q,h;
    int i;
    scanf("%d%d",&n,&q);
    BuildTree(0,1,n);
    for( i = 1; i <= n; i ++ )
    {
        scanf("%d",&h);
        Insert(0,i,h);
    }
    for( i = 0; i <= 12; i ++ )
        cout<<i<<" "<<tree[i].L<<" "<<tree[i].R<<" "<<tree[i].minV<<" "<<tree[i].maxV<<endl;
    for( i = 0; i < q; i ++ )
    {
        int s,e;
        scanf("%d%d", &s,&e);
        minV = INF;
        maxV = -INF;
        Query(0,s,e);
        printf("%d\n",maxV - minV);
    }
    return 0;
}
/*
6 3
1
7
3
4
2
5
1 5
4 6
2 2
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值