HDU 4734-F(x)(数位DP)

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3567    Accepted Submission(s): 1330



Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5717  5716  5715  5714  5713

题目意思:
数i在0~B的范围内,求F(i)小于F(A)的个数。

解题思路:
数位DP。
dp[i][j]表示i位数,F值小于等于j的数的个数。
注意边界的各种情况的判断。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 100010
int a,b;
int data[22];
int dp[22][20000];//dp[i][j]表示i位数,F值小于等于j的数的个数
int dfs(int pos,int num,int flag)
{
    if(pos==-1) return num>=0;
    if(num<0) return 0;
    if(!flag&&dp[pos][num]>=0) return dp[pos][num];
    int res=0,u=flag?data[pos]:9;
    for(int i=0; i<=u; ++i)
        res+=dfs(pos-1,num-i*(1<<pos),flag&&i==u);//dp[i][j]+=dp[i-1][j-k*(1<<(i-1))]
    if(!flag) dp[pos][num]=res;
    return res;
}

int doit()//分离数的各个位
{
    int al=0,res=0,bl=0;
    while(b)
    {
        data[bl++]=b%10;
        b/=10;
    }
    while(a)
    {
        res+=(a%10)*(1<<al);//2^al
        al++;
        a/=10;
    }
    return dfs(bl-1,res,true);
}
int main()
{

    ios::sync_with_stdio(false);
    int t,cnt=0;
    cin>>t;
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        cin>>a>>b;
        cout<<"Case #"<<++cnt<<": "<<doit()<<endl;
    }
    return 0;
}
/*
3
0 100
1 10
5 100
*/

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值