HDU 5769-Substring(后缀数组-不相同的子串的个数)

Substring

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 973    Accepted Submission(s): 393


Problem Description
?? is practicing his program skill, and now he is given a string, he has to calculate the total number of its distinct substrings. 
But ?? thinks that is too easy, he wants to make this problem more interesting. 
?? likes a character X very much, so he wants to know the number of distinct substrings which contains at least one X. 
However, ?? is unable to solve it, please help him.
 

Input
The first line of the input gives the number of test cases T;T test cases follow. 
Each test case is consist of 2 lines: 
First line is a character X, and second line is a string S. 
X is a lowercase letter, and S contains lowercase letters(‘a’-‘z’) only.

T<=30 
1<=|S|<=10^5 
The sum of |S| in all the test cases is no more than 700,000.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the answer you get for that case.
 

Sample Input
  
  
2 a abc b bbb
 

Sample Output
  
  
Case #1: 3 Case #2: 3
Hint
In first case, all distinct substrings containing at least one a: a, ab, abc. In second case, all distinct substrings containing at least one b: b, bb, bbb.
 

Author
FZU
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5808  5807  5806  5805  5804 

题目意思:

有一个子串X,一个母串str,求str中不相同的子串个数且至少含有一个X串。

解题思路:



#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define maxn 1000010

using namespace std;
//以下为倍增算法求后缀数组
int wa[maxn],wb[maxn],wv[maxn],Ws[maxn],nxt[maxn];
int sa[maxn],Rank[maxn],height[maxn];
char str[maxn],X[maxn];
int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b]&&r[a+l]==r[b+l];
}
void da(const char *r,int *sa,int n,int m)
{
    int i,j,p,*x=wa,*y=wb,*t;
    for(i=0; i<m; i++) Ws[i]=0;
    for(i=0; i<n; i++) Ws[x[i]=r[i]]++;
    for(i=1; i<m; i++) Ws[i]+=Ws[i-1];
    for(i=n-1; i>=0; i--) sa[--Ws[x[i]]]=i;
    for(j=1,p=1; p<n; j*=2,m=p)
    {
        for(p=0,i=n-j; i<n; i++) y[p++]=i;
        for(i=0; i<n; i++) if(sa[i]>=j) y[p++]=sa[i]-j;
        for(i=0; i<n; i++) wv[i]=x[y[i]];
        for(i=0; i<m; i++) Ws[i]=0;
        for(i=0; i<n; i++) Ws[wv[i]]++;
        for(i=1; i<m; i++) Ws[i]+=Ws[i-1];
        for(i=n-1; i>=0; i--) sa[--Ws[wv[i]]]=y[i];
        for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1; i<n; i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
}

//求height数组
void calheight(const char *r,int *sa,int n)
{
    int i,j,k=0;
    for(i=1; i<=n; i++) Rank[sa[i]]=i;
    for(i=0; i<n; height[Rank[i++]]=k)
        for(k?k--:0,j=sa[Rank[i]-1]; r[i+k]==r[j+k]; k++);
    return;
}

int slove(int n)
{
    int sum=0;
    for(int i=1; i<=n; i++)
        sum+=n-sa[i]-height[i];
    return sum;
}
int main()
{
    int t,ca=0;
    scanf("%d",&t);
    while(t--)
    {

        scanf("%s%s",X,str);
        int n=strlen(str);
        int temp=n;
        long long ans=0;
        for(int i=n-1; i>=0; i--)
        {
            if(str[i]==X[0])
            {
                temp=i; cout<<temp<<"===";
            }
           else cout<<temp<<"***";
            nxt[i]=temp;
        }
        da(str,sa,strlen(str)+1,130);
        calheight(str,sa,strlen(str));
        for(int i=1; i<=n; i++)
            // printf("%d %d\n",sa[i],height[i]);
            // printf("%d\n",slove(strlen(str)));
            ans+=n-max(nxt[sa[i]],sa[i]+height[i]);
        printf("Case #%d: %I64d\n",++ca,ans);
    }
    return 0;
}
/**
2
a
abc
b
bbb
**/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值