HDU 5726-GCD(暴力+map)

79 篇文章 0 订阅

GCD

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2527    Accepted Submission(s): 892


Problem Description
Give you a sequence of  N(N100,000)  integers :  a1,...,an(0<ai1000,000,000) . There are  Q(Q100,000)  queries. For each query  l,r  you have to calculate  gcd(al,,al+1,...,ar)  and count the number of pairs (l,r)(1l<rN) such that  gcd(al,al+1,...,ar)  equal  gcd(al,al+1,...,ar) .
 

Input
The first line of input contains a number  T , which stands for the number of test cases you need to solve.

The first line of each case contains a number  N , denoting the number of integers.

The second line contains  N  integers,  a1,...,an(0<ai1000,000,000) .

The third line contains a number  Q , denoting the number of queries.

For the next  Q  lines, i-th line contains two number , stand for the  li,ri , stand for the i-th queries.
 

Output
For each case, you need to output “Case #:t” at the beginning.(with quotes,  t  means the number of the test case, begin from 1).

For each query, you need to output the two numbers in a line. The first number stands for  gcd(al,al+1,...,ar)  and the second number stands for the number of pairs (l,r)  such that  gcd(al,al+1,...,ar)  equal  gcd(al,al+1,...,ar) .
 

Sample Input
  
  
1 5 1 2 4 6 7 4 1 5 2 4 3 4 4 4
 

Sample Output
  
  
Case #1: 1 8 2 4 2 4 6 1
 

Author
HIT
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5808  5807  5806  5805  5804

题目意思:

有一串N个数字,Q个查询给出一组区间,求区间内各个数的GCD以及共有多少个区间的书的GCD与给定区间的GCD相同。

解题思路:



下面的代码是标程,根据题解说说自己的理解。
每输入一个数a[i]就进行一次处理:依次计算以a为结尾的子序列的GCD,就是说a所在的位置是区间的最右端点,
定义vector<pair<int,int> > g[maxn];其中first:gcd;second:区间左端点。
即first=GCD(a[second],a[i]),g[i][j]中i表示输入的第i个数,j表示当前处理第i个数时保存的第j组不同GCD。
定义map<ll,ll>m;m[i]=j,表示GCD为i的区间共有j个。
所以保存记录map的时候,m[g[i][j].first]+=(j==g[i].size()-1?i+1:g[i][j+1].second)-g[i][j].second;
对单个的a[i]GCD为本身进行了特判,其它的就是利用下一个的区间左端减去当前区间左端的差值作为当前新增的GCD个数。
扫map之前找GCD的查询的时,固定右端点,查询左端点。
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <map>
#include <vector>
#include <cstdlib>
#define maxn 100010
#define ll long long
using namespace std;
map<ll,ll>m;
vector<pair<int,int> > g[maxn];//first:gcd;second:区间左端点
int gcd(int a,int b)//求ab两数的最大公约数
{
    return b?gcd(b,a%b):a;
}
ll a[maxn];
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int t,ca=0;
    cin>>t;
    while(t--)
    {
        m.clear();
        cout<<"Case #"<<++ca<<":"<<endl;
        int n,q,l,r,i,j;
        cin>>n;
        for(int i=0; i<=n; ++i)
            g[i].clear();//不清空会超内存
        //预处理出所有的以L开头的左区间的gcd(al,al+1,...,ar):
        //对于每个数字,记录从开始到当前数字的区间的子区间中以当前数字为结尾区间的gcd
        //相同gcd区间合并
        for(i=1; i<=n; ++i)
        {
            int last=0;
            cin>>a[i];
            for(j=0; j<g[i-1].size(); ++j)
            {
                int tmp=gcd(a[i],g[i-1][j].first);
                if(tmp==last) continue;//上一个出现过该gcd
                last=tmp;
                g[i].push_back(make_pair(tmp,g[i-1][j].second));
            }
            if(last!=a[i])//当前a与自己的gcd在上面的循环中没有出现过
                g[i].push_back(make_pair(a[i],i));
            //用一个map来记录,gcd值为key的有多少个
            for(j=0; j<g[i].size(); ++j)
            {
                m[g[i][j].first]+=(j==g[i].size()-1?i+1:g[i][j+1].second)-g[i][j].second;
                // cout<<g[i][j].first<<" "<<m[g[i][j].first]<<endl;
            }
        }
        cin>>q;
        for(i=0; i<q; ++i)
        {
            cin>>l>>r;
            for(j=0; j<g[r].size(); ++j)//对于每个询问只需要查询对应gcd(al,al+1,...,ar)为多少
                if(g[r][j].second>l) break;
            cout<<g[r][j-1].first<<" "<<m[g[r][j-1].first]<<endl;
        }
    }
    return 0;
}
/**
1
5
1 2 4 6 7
4
1 5
2 4
3 4
4 4
**/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值