POJ 1523-SPF(Tarjan算法-关节点)

SPF
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8018 Accepted: 3675

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source


题目意思:

给出网络中两两节点连接的情况,求是否存在关节点,若存在,分成几个联通的子网络。

解题思路:

根据题目输入建一个无向图,然后用Tarjan算法求解即可。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
using namespace std;
#define INF 0xfffffff
#define maxn 1010
int edge[maxn][maxn];//邻接矩阵
int vis[maxn];//顶点访问状态
int n;//顶点数目
int tmpdfn;//dfs过程中记录当前深度优先搜索序数
int dfn[maxn];
int low[maxn];
int son;//根节点子女数(大于2为关节点)
int subnets[maxn];//每个节点(去掉该节点后的)连通分量数
void dfs(int u)//求得low
{
    for(int v=1; v<=n; ++v)
        if(edge[u][v])//u与v邻接
        {
            if(!vis[v])//v未访问,v是u的儿子节点
            {
                vis[v]=1;
                ++tmpdfn;
                dfn[v]=low[v]=tmpdfn;
                dfs(v);//low已经求得
                low[u]=min(low[u],low[v]);//回退的时候,计算顶点u的low值
                if(low[v]>=dfn[u])
                {
                    if(u!=1) ++subnets[u];//去掉该节点后的连通分量数
                    if(u==1) ++son;//根节点子女数大于2为关节点
                }
            }
            else low[u]=min(low[u],dfn[v]);//v已经访问过,v是u的祖先节点,(v,u)是回边
        }
}
void init()//初始化
{
    low[1]=dfn[1]=1;
    tmpdfn=1;
    son=0;
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    memset(subnets,0,sizeof(subnets));
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int i;
    int u,v;//顶点对
    int flag;//标志是否找到
    int ca=1;
    while(1)
    {
        cin>>u;
        if(u==0) break;//全部输入结束
        memset(edge,0,sizeof(edge));
        n=0;
        cin>>v;
        if(u>n) n=u;
        if(v>n) n=v;
        edge[u][v]=edge[v][u]=1;
        while(1)
        {
            cin>>u;
            if(u==0) break;//当前组输入结束
            cin>>v;
            if(u>n) n=u;
            if(v>n) n=v;
            edge[u][v]=edge[v][u]=1;
        }
        if(ca>1) puts("");//保证最后一个网络输出置换木有空行
        cout<<"Network #"<<ca++<<endl;
        init();//初始化
        dfs(1);//从顶点1开始DFS
        if(son>1) subnets[1]=son-1;
        flag=0;
        for(i=1; i<=n; ++i)
            if(subnets[i])
            {
                flag=1;
                cout<<"  SPF node "<<i<<" leaves "<<subnets[i]+1<<" subnets"<<endl;
            }
        if(!flag) puts("  No SPF nodes");
    }
    return 0;
}
/**
1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0
**/


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值