HDU 5901-Count primes(1e11以内素数的个数)

25 篇文章 1 订阅

Count primes

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 971    Accepted Submission(s): 520


Problem Description
Easy question! Calculate how many primes between [1...n]!
 

Input
Each line contain one integer n(1 <= n <= 1e11).Process to end of file.
 

Output
For each case, output the number of primes in interval [1...n]
 

Sample Input
  
  
2 3 10
 

Sample Output
  
  
1 2 4
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5900  5899  5898  5897  5896 

 

题目意思:

输入N,求N(N最大取到 1e11)以内素数的个数。

解题思路:

智商和刷题量的完全碾压…以下代码全是我从网上搜罗的,膜一下大神们…Orz

AC代码①

#include <bits/stdc++.h>
#define ll long long
using namespace std;
ll f[340000],g[340000],n;
void init(){
    ll i,j,m;
    for(m=1;m*m<=n;++m)f[m]=n/m-1;
    for(i=1;i<=m;++i)g[i]=i-1;
    for(i=2;i<=m;++i){
        if(g[i]==g[i-1])continue;
        for(j=1;j<=min(m-1,n/i/i);++j){
            if(i*j<m)f[j]-=f[i*j]-g[i-1];
            else f[j]-=g[n/i/j]-g[i-1];
        }
        for(j=m;j>=i*i;--j)g[j]-=g[j/i]-g[i-1];
    }
}
int main(){
    while(scanf("%I64d",&n)!=EOF){
        init();
        cout<<f[1]<<endl;
    }
    return 0;
}

AC代码②


//Meisell-Lehmer  
#include<cstdio>  
#include<cmath>  
using namespace std;  
#define LL long long  
const int N = 5e6 + 2;  
bool np[N];  
int prime[N], pi[N];  
int getprime()  
{  
    int cnt = 0;  
    np[0] = np[1] = true;  
    pi[0] = pi[1] = 0;  
    for(int i = 2; i < N; ++i)  
    {  
        if(!np[i]) prime[++cnt] = i;  
        pi[i] = cnt;  
        for(int j = 1; j <= cnt && i * prime[j] < N; ++j)  
        {  
            np[i * prime[j]] = true;  
            if(i % prime[j] == 0)   break;  
        }  
    }  
    return cnt;  
}  
const int M = 7;  
const int PM = 2 * 3 * 5 * 7 * 11 * 13 * 17;  
int phi[PM + 1][M + 1], sz[M + 1];  
void init()  
{  
    getprime();  
    sz[0] = 1;  
    for(int i = 0; i <= PM; ++i)  phi[i][0] = i;  
    for(int i = 1; i <= M; ++i)  
    {  
        sz[i] = prime[i] * sz[i - 1];  
        for(int j = 1; j <= PM; ++j) phi[j][i] = phi[j][i - 1] - phi[j / prime[i]][i - 1];  
    }  
}  
int sqrt2(LL x)  
{  
    LL r = (LL)sqrt(x - 0.1);  
    while(r * r <= x)   ++r;  
    return int(r - 1);  
}  
int sqrt3(LL x)  
{  
    LL r = (LL)cbrt(x - 0.1);  
    while(r * r * r <= x)   ++r;  
    return int(r - 1);  
}  
LL getphi(LL x, int s)  
{  
    if(s == 0)  return x;  
    if(s <= M)  return phi[x % sz[s]][s] + (x / sz[s]) * phi[sz[s]][s];  
    if(x <= prime[s]*prime[s])   return pi[x] - s + 1;  
    if(x <= prime[s]*prime[s]*prime[s] && x < N)  
    {  
        int s2x = pi[sqrt2(x)];  
        LL ans = pi[x] - (s2x + s - 2) * (s2x - s + 1) / 2;  
        for(int i = s + 1; i <= s2x; ++i) ans += pi[x / prime[i]];  
        return ans;  
    }  
    return getphi(x, s - 1) - getphi(x / prime[s], s - 1);  
}  
LL getpi(LL x)  
{  
    if(x < N)   return pi[x];  
    LL ans = getphi(x, pi[sqrt3(x)]) + pi[sqrt3(x)] - 1;  
    for(int i = pi[sqrt3(x)] + 1, ed = pi[sqrt2(x)]; i <= ed; ++i) ans -= getpi(x / prime[i]) - i + 1;  
    return ans;  
}  
LL lehmer_pi(LL x)  
{  
    if(x < N)   return pi[x];  
    int a = (int)lehmer_pi(sqrt2(sqrt2(x)));  
    int b = (int)lehmer_pi(sqrt2(x));  
    int c = (int)lehmer_pi(sqrt3(x));  
    LL sum = getphi(x, a) +(LL)(b + a - 2) * (b - a + 1) / 2;  
    for (int i = a + 1; i <= b; i++)  
    {  
        LL w = x / prime[i];  
        sum -= lehmer_pi(w);  
        if (i > c) continue;  
        LL lim = lehmer_pi(sqrt2(w));  
        for (int j = i; j <= lim; j++) sum -= lehmer_pi(w / prime[j]) - (j - 1);  
    }  
    return sum;  
}  
int main()   
{  
    init();  
    LL n;  
    while(~scanf("%lld",&n))  
    {  
        printf("%lld\n",lehmer_pi(n));  
    }  
    return 0;  
}  

超内存代码③(超了一万):
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <math.h>
#include<bits/stdc++.h>
#include<malloc.h>

#define XPREVN		(22*1000*1000)				/**/
#define XSQRTPREVN	(5*1000)
#define XPREVPI		(2*1000*1000)				/* PI(XPREVN) : 3957809 */

int		*X_small_prime,  X_pi_small_prime;
int		*X_pi_prev_N, *X_prev_V;

#define XPREVDM		(7)
#define XPREVQ		(2*3*5*7*11*13*17)
#define XPREVPHQ	(1*2*4*6*10*12*16)

typedef long long	LLong;

stack st;
LLong phiX_p( LLong x, LLong a )
{
    if( a == XPREVDM )
        return x / XPREVQ * XPREVPHQ + X_prev_V[ x % XPREVQ ];
    if( x < X_small_prime[a-1] )
        return 1;
    return phiX_p( x, a - 1 ) - phiX_p( x / X_small_prime[a-1], a - 1 );
}
LLong phiX_p( LLong x, LLong a )
{
    long long ans;
    if( a == XPREVDM ) ans=x / XPREVQ * XPREVPHQ + X_prev_V[ x % XPREVQ ];
    if( x < X_small_prime[a-1] ) ans=1;
    return ans;
}


LLong phiX( LLong X )
{
    LLong cubeRootX, max, len3, len2, s, i, k;
    LLong sum, p;
    if( X <= XPREVN )
        return X_pi_prev_N[X];

    max   = (LLong)(pow( (double)X, 2./3 ) + 2);
    cubeRootX = (LLong)(pow( (double)X, 1./3 ) + .5);
    if( cubeRootX*cubeRootX*cubeRootX > X )
        --cubeRootX;
    len3 = X_pi_prev_N[cubeRootX];

    sum = 0;
    s = 0;
    k = max -1 ;
    for( i = len3; ; ++i )
    {
        p = X_small_prime[i];
        if( p * p > X ) break;

        s += X_pi_prev_N[k] - X_pi_prev_N[(int)((double)X/p)];
        k = (int)((double)X/p);

        sum += s;
    }
    len2 = X_pi_prev_N[p-1];

    sum = (len2-len3)*X_pi_prev_N[max-1] - sum;
    sum = len3 * (len3-1)/2 - len2 * (len2-1) / 2 + sum;

    return phiX_p( X, len3 ) - sum + len3 - 1;
}

void initSmallPrime()
{
    char *mark = (char*)calloc(1,XPREVN/2+1);
    int i, j;

    X_small_prime = (int*)calloc(sizeof(int),XPREVPI );
    X_pi_prev_N   = (int*)calloc(sizeof(int),XPREVN+1);
    X_prev_V	  = (int*)calloc(sizeof(int),XPREVQ+1);

    for( i = 3; i <= XSQRTPREVN; i += 2 )
    {
        if( mark[i/2] ) continue;
        for( j = i*i/2; j <= XPREVN/2; j+=i )
            mark[j] = 1;
    }
    X_small_prime[0] = 2;
    X_pi_small_prime = 1;
    X_pi_prev_N[0] = X_pi_prev_N[1] = 0;
    X_pi_prev_N[2] = 1;
    for( i = 3; i <= XPREVN; i += 2 )
    {
        if( mark[i/2] )
        {
            X_pi_prev_N[i+1] = X_pi_prev_N[i] = X_pi_prev_N[i-1];
        }
        else
        {
            X_pi_prev_N[i+1] = X_pi_prev_N[i] = 1 + X_pi_prev_N[i-1];
            X_small_prime[X_pi_small_prime++] = i;
        }
    }
    free(mark);

    for( i = 0; i < XPREVQ; ++i )
        X_prev_V[i] = i;
    for( i = 1; i <= XPREVDM; ++i )
        for( j = XPREVQ-1; j >= 0; --j )
            X_prev_V[j] -= X_prev_V[ j/X_small_prime[i-1] ];
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/x/read.txt","r",stdin);
    freopen("G:/x/out.txt","w",stdout);
#endif
    LLong	x, r;
    initSmallPrime();

    while(~scanf( "%I64d", &x ))
    {
        r = phiX( x );
        printf("%I64d\n",r);
    }
    free(X_small_prime);
    free(X_pi_prev_N);
    free(X_prev_V);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值