POJ 1068-Parencodings(模拟-包含括号个数)

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25510 Accepted: 15016

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source


题目意思:

S		(((()()())))  括号表示

P-sequence	4 5 6 6 6 6   每个右括号前面的左括号数目

W-sequence	1 1 1 4 5 6   每对括号所包含的括号对数(包括其自身)
给出P序列,求其W序列。

解题思路:

必须先提醒一句,这题的测试数据中,n肯定大于20(虽然给的范围到20),一开始开到21,直接RE…Orz
首先根据P序列还原出S序列:P[i]-P[i-1]是当前应在一个右括号前面插入的左括号数;
然后从前往后扫出未匹配的第一个右括号,再从当前位置往前扫出未匹配的第一个左括号;
最后在当前匹配的左右括号之间扫描已经匹配的括号数目,依次++即可。


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
struct N
{
    char c;//存储'('或')'
    bool vis;//判断是否被访问
    int num;//c==')'时记录其包含的括号数
} node[101];

int a[101];//坑爹测试数据,开21果断RE…
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        memset(a,0,sizeof(a));
        cin>>a[0];
        int cnt=0;
        for(int i=0; i<a[0]; ++i)//根据输入还原S(即括号表示)并初始化
        {
            node[cnt].c='(';
            node[cnt].vis=false;
            node[cnt++].num=0;
        }
        node[cnt].c=')';
        node[cnt].vis=false;
        node[cnt++].num=0;
        for(int i=1; i<n; ++i)
        {
            cin>>a[i];
            for(int j=0; j<a[i]-a[i-1]; ++j)
            {
                node[cnt].c='(';
                node[cnt].vis=false;
                node[cnt++].num=0;
            }
            node[cnt].c=')';
            node[cnt].vis=false;
            node[cnt++].num=0;
        }
        /*for(int i=0; i<cnt; ++i)//输出S
            cout<<node[i].c<<" ";
        cout<<endl;*/
        bool flag=true;//判断当前是否仍有未匹配的括号
        while(flag)
        {
            flag=false;
            for(int i=1; i<cnt; ++i)//右括号‘)’
                if(node[i].c==')'&&node[i].vis==false)
                    for(int j=i-1; j>=0; --j)//左括号‘(’
                        if(node[j].c=='('&&node[j].vis==false)
                        {
                            node[j].vis=node[i].vis=true;
                            node[i].num=1;
                            flag=true;
                            int k;
                            for(k=j; k<i; ++k)
                                if(node[k].c==')'&&node[k].vis==true)
                                    ++node[i].num;//计算包含的括号数
                            break;
                        }
        }
        for(int i=0; i<cnt; ++i)
            if(node[i].c==')')
                cout<<node[i].num<<" ";
        cout<<endl;
    }
    return 0;
}
/*
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值