POJ 3253-Fence Repair(哈夫曼树-最小值优先队列)

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44152 Accepted: 14405

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source


题目意思:

给出一块木板上的N个切口将木板分割的大小,切割的费用是将木板分成两段后这两段的长度之和。
求最小费用。

解题思路:

哈夫曼树,每次取两个最小的,直到剩下最后一个元素。
使用最小堆的优先队列最方便,也可以暴力解决。

priority_queue调用 STL里面的 make_heap(), pop_heap(), push_heap() 算法实现,也算是堆的另外一种形式。先写一个用 STL 里面堆算法实现的与真正的STL里面的 priority_queue用法相似的priority_queue, 以加深对 priority_queue 的理解

#include <iostream>
#include <algorithm>
#include <vector>
 
using  namespace  std;
 
class  priority_queue
{
     private :
         vector< int > data;
         
     public :
         void  push( int  t ){
             data.push_back(t);
             push_heap( data.begin(), data.end());
         }
         
         void  pop(){
             pop_heap( data.begin(), data.end() );
             data.pop_back();
         }
         
         int  top() { return  data.front(); }
         int  size() { return  data.size(); }
         bool  empty() { return  data.empty(); }
};
 
 
int  main()
{
     priority_queue test;
     test.push( 3 );
     test.push( 5 );
     test.push( 2 );
     test.push( 4 );
     
     while ( !test.empty() ){
         cout << test.top() << endl;
         test.pop(); }
         
     return  0;
 
}
 
STL里面的 priority_queue 写法与此相似,只是增加了模板及相关的迭代器什么的。 

priority_queue 对于基本类型的使用方法相对简单。他的模板声明带有三个参数:
priority_queue<Type, Container, Functional>

其中Type 为数据类型, Container 为保存数据的容器,Functional 为元素比较方式。
Container 必须是用数组实现的容器,比如 vector, deque 但不能用 list.
STL里面默认用的是 vector. 比较方式默认用 operator< , 所以如果你把后面俩个 参数缺省的话,
优先队列就是大顶堆,队头元素最大。
 
#include <iostream>
#include <queue>
 
using  namespace  std;
 
int  main(){
     priority_queue< int > q;
     
     for ( int  i= 0; i< 10; ++i ) q.push( rand () );
     while ( !q.empty() ){
         cout << q.top() << endl;
         q.pop();
     }
     
     getchar ();
     return  0;
}
 
如果要用到小顶堆,则一般要把模板的三个参数都带进去。
STL里面定义了一个仿函数 greater<>,对于基本类型可以用这个仿函数声明小顶堆
 
#include <iostream>
#include <queue>
 
using  namespace  std;
 
int  main(){
     priority_queue< int , vector< int >, greater< int > > q;
     
     for ( int  i= 0; i< 10; ++i ) q.push( rand () );
     while ( !q.empty() ){
         cout << q.top() << endl;
         q.pop();
     }
     
     getchar ();
     return  0;
}

 

对于自定义类型,则必须自己重载 operator< 或者自己写仿函数
 
#include <iostream>
#include <queue>
 
using  namespace  std;
 
struct  Node{
     int  x, y;
     Node( int  a= 0, int  b= 0 ):
         x(a), y(b) {}
};
 
bool  operator<( Node a, Node b ){
     if ( a.x== b.x ) return  a.y> b.y;
     return  a.x> b.x;
}
 
int  main(){
     priority_queue<Node> q;
     
     for ( int  i= 0; i< 10; ++i )
     q.push( Node( rand (), rand () ) );
     
     while ( !q.empty() ){
         cout << q.top().x << ' '  << q.top().y << endl;
         q.pop();
     }
     
     getchar ();
     return  0;
}

自定义类型重载 operator< 后,声明对象时就可以只带一个模板参数。
但此时不能像基本类型这样声明
priority_queue<Node, vector<Node>, greater<Node> >;
原因是 greater<Node> 没有定义,如果想用这种方法定义 则可以按如下方式:
 
#include <iostream>
#include <queue>
 
using  namespace  std;
 
struct  Node{
     int  x, y;
     Node( int  a= 0, int  b= 0 ):
         x(a), y(b) {}
};
 
struct  cmp{
     bool  operator() ( Node a, Node b ){
         if ( a.x== b.x ) return  a.y> b.y;
         
         return  a.x> b.x; }
};
 
int  main(){
     priority_queue<Node, vector<Node>, cmp> q;
     
     for ( int  i= 0; i< 10; ++i )
     q.push( Node( rand (), rand () ) );
     
     while ( !q.empty() ){
         cout << q.top().x << ' '  << q.top().y << endl;
         q.pop();
     }
     
     getchar ();
     return  0;
}
 
 
//以上代码实现的是一个小顶堆

转载:http://blog.chinaunix.net/space.php?uid=533684&do=blog&cuid=2615612

ps:如果重载operator > 可直接使用priority_queue<Node,vector<Node>,greater<Node>>


#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>

using namespace std;
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    while(cin>>n)
    {
        long long ans=0,a,b;//结果可能长达长整型
        int s;
        priority_queue<int,vector<int>,greater<int> >que;//最小值优先
        for(int i=0; i<n; ++i)
        {
            cin>>s;//读取初值
            que.push(s);
        }
        if(que.size()==1)//特判只有1个元素的情况
            ans=que.top();
        else
            while(que.size()>1)
            {
                a=que.top();//取出最小的两个值,然后将其出栈
                que.pop();
                b=que.top();
                que.pop();
                ans+=(a+b);
                que.push(a+b);//注意是两值之和入栈而不是ans
            }
        cout<<ans<<endl;
    }
    return 0;
}
/*
3
8
5
8
*/


评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值