POJ 1276-Cash Machine(多重部分和-dp)

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34117 Accepted: 12362

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source


题目意思:

现金cash元,有N种零钱,依次给出数量及其面值。求出用这些零钱能够换零的不超过cash的最大金额。

解题思路:

多重部分和的模板,dp[i]保存的是能否得到金额i,不小于零时表示能够得到。然后从cash往下枚举dp数组,一旦满足就输出i。
因为用二维dp数组过大,所以使用一维重复利用。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
using namespace std;
#define INF 0xfffffff
#define MAXN 100005
int a[MAXN],m[MAXN];
int cash,n;
void init()
{
    memset(dp,-1,sizeof(dp));
    memset(a,0,sizeof(a));
    memset(m,0,sizeof(m));
}
int dp[MAXN];

void solve()
{
    dp[0]=0;
    int i,j;
    for(i=0; i<n; ++i)
        for(j=0; j<=cash; ++j)
        {
            if(dp[j]>=0) dp[j]=m[i];
            else if(j<a[i]||dp[j-a[i]]<=0) dp[j]=-1;
            else dp[j]=dp[j-a[i]]-1;
        }
    for(int i=cash; i>=0; --i)//从cash往下枚举
        if(dp[i]>=0)
        {
            cout<<i<<endl;
            break;
        }
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
    //freopen("F:/cb/out.txt","w",stdout);
#endif
    while(~scanf("%d%d",&cash,&n))
    {
        init();
        for(int i=0; i<n; ++i)
            cin>>m[i]>>a[i];
        solve();
    }
    return 0;
}
/*
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值