POJ 2251-Dungeon Master(BFS-三维迷宫)

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30842 Accepted: 11948

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

Source


题目意思:

给出一个3D迷宫的层数和长宽,输入迷宫,可以上下东西南北六个方向移动,计算从S走到E需要的步数。

解题思路:

BFS,用队列存储可以走到的每一步,枚举搜索直到终点。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 40
char ma[MAXN][MAXN][MAXN];//存迷宫地图
int step[MAXN][MAXN][MAXN];//走的步数
bool vis[MAXN][MAXN][MAXN];//是否访问过
int dir[6][3]= {0,0,1, 0,0,-1, 0,1,0, 0,-1,0, 1,0,0, -1,0,0}; //上下东西南北
bool flag;//能否走出迷宫
int d,r,c,ans;//深度、长度、宽度、总步数
struct Node
{
    int x,y,z;//深、长、宽
} s,e;//起始点和终点

void BFS()
{
    queue<Node> q;
    vis[s.z][s.x][s.y]=true;
    q.push(s);
    while(!q.empty())
    {
        Node pos=q.front(),temp;
        q.pop();
        for(int i=0; i<6; ++i)
        {
            temp.z=pos.z+dir[i][0];
            temp.x=pos.x+dir[i][1];
            temp.y=pos.y+dir[i][2];
            //是否访问、是否能走、范围是否在迷宫内
            if(!vis[temp.z][temp.x][temp.y]&&ma[temp.z][temp.x][temp.y]!='#'&&temp.x>=0&&temp.x<r&&temp.y>=0&&temp.y<c&&temp.z>=0&&temp.z<d)
            {
                if(temp.x==e.x&&temp.y==e.y&&temp.z==e.z)//到达终点
                {
                    ans=step[pos.z][pos.x][pos.y]+1;
                    flag=true;
                    return;
                }
                vis[temp.z][temp.x][temp.y]=true;//标记访问
                step[temp.z][temp.x][temp.y]=step[pos.z][pos.x][pos.y]+1;//增加步数
                q.push(temp);
            }
        }
    }
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("F:/cb/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    while(cin>>d>>r>>c&&d&&r&&c)
    {
        flag=false;
        ans=0;
        memset(ma,'\0',sizeof(ma));
        memset(step,0,sizeof(step));
        memset(vis,false,sizeof(vis));
        for(int i=0; i<d; ++i)
            for(int j=0; j<r; ++j)
                for(int k=0; k<c; ++k)
                {
                    cin>>ma[i][j][k];
                    if(ma[i][j][k]=='S')//起点
                        s.z=i,s.x=j,s.y=k;
                    else if(ma[i][j][k]=='E')//终点
                        e.z=i,e.x=j,e.y=k;
                }
        BFS();
        if(flag) cout<<"Escaped in "<<ans<<" minute(s)."<<endl;
        else cout<<"Trapped!"<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值