POJ 2409-Let it Bead(Polya定理-旋转+翻转 串项链)

Let it Bead
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5895 Accepted: 3950

Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced. 

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output

1
2
3
5
8
13
21

Source


题目意思:

给定m种颜色的珠子,每种颜色的珠子个数不限,将它们串成长度为n的项链,计算一共能做成多少种不重复的项链。
两条项链相同,当且仅当两条项链能通过旋转或者翻转后能重合在一起。

解题思路:

①旋转,将项链顺时针旋转i格之后,其循环节数是gcd(n,i),计算出所有不同的着色方案;
②翻转,不同的方法数=循环群个数*pow(不同颜色数,循环节数)之和,然后再除以所有的置换数之和(2*n),其中:
当n为奇数,共有n个循环节数为(n+1)/2的循环群;
当n为偶数,共有n/2个循环节数为(n+2)/2的循环群和n/2个循环节数为n/2的循环群。

#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
int gcd(int a,int b)
{
    return (a%b!=0?(gcd(b,a%b)):b);
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    int n,m;
    while(scanf("%d%d",&m,&n))
    {
        if(m==0&&n==0) break;
        int ans=0;
        for(int i=1; i<=n; ++i)//旋转,计算出着色方案
        {
            int t=gcd(n,i);
            ans+=(int)(pow(m,t));
        }
        //翻转,计算出循环群个数
        if(n&1)//奇数
            ans+=(int)(n*pow(m,(n+1)/2));
        else//偶数
        {
            ans+=(int)(n/2*pow(m,(n+2)/2));
            ans+=(int)(n/2*pow(m,(n)/2));
        }
        ans/=2*n;//置换群个数是2*n
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值