专题二 1011

一. 题目编号

专题二 1011

Oil Deposits

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*’, representing the absence of oil, or `@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

Mid-Central USA 1997

二. 简单题意

Description

GeoSurvComp地质调查公司负责探测地下石油储藏。 GeoSurvComp现在在一块矩形区域探测石油,并把这个大区域分成了很多小块。他们通过专业设备,来分析每个小块中是否蕴藏石油。如果这些蕴藏石油的小方格相邻,那么他们被认为是同一油藏的一部分。在这块矩形区域,可能有很多油藏。你的任务是确定有多少不同的油藏。

Input

输入可能有多个矩形区域(即可能有多组测试)。每个矩形区域的起始行包含m和n,表示行和列的数量,1<=n,m<=100,如果m =0表示输入的结束,接下来是n行,每行m个字符。每个字符对应一个小方格,并且要么是’*’,代表没有油,要么是’@’,表示有油。

Output

对于每一个矩形区域,输出油藏的数量。两个小方格是相邻的,当且仅当他们水平或者垂直或者对角线相邻(即8个方向)。

即:找有几块不同的油田,@表示有油,周围8个方向的连在一块记为一个

三. 解题思路形成过程

属于深度优先查找的问题,依次搜索图中每个点的八邻域,并注意标记访问。

四. 感想

一道经典的搜索题,原来的四方向变成了八个方向,其实是一样的
但注意遍历的时候多遍历几个。

五. AC代码

#include <iostream>
#include <cstring>    
using namespace std; 
bool visit[110][110]; //重复访问控制   
char maze[110][110];  //地图   
int dir[8][2]={{-1,0},{1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,-1},{1,1}};//八个方向   
int sum,m,n,sx,sy; 
bool isbound(int a,int b){  //判断边界   
    if(a<1 || a>m || b<1 || b>n)return true; 
    return false; 
} 
void dfs(int sx,int sy){  //对每一个点进行深搜   


    for(int i=0;i<8;i++) 
    { 
        if(maze[sx+dir[i][0]][sy+dir[i][1]]=='*')continue;//障碍返回   
        if(isbound(sx+dir[i][0],sy+dir[i][1]))continue;//边界返回   
        if(visit[sx+dir[i][0]][sy+dir[i][1]])continue;//已访问,返回   
          visit[sx+dir[i][0]][sy+dir[i][1]]=1; //标记已访问,防止重复访问   
          dfs(sx+dir[i][0],sy+dir[i][1]); 
    } 
} 
int main() 
{ 
    while(cin>>m>>n) 
    { 
        if(m==0)break; 
        memset(visit,0,sizeof(visit)); 
        for(int i=1;i<=m;i++){ 
            for(int j=1;j<=n;j++){ 
                cin>>maze[i][j]; 
            } 
        } 
        sum=0; 
        for(int i=1;i<=m;i++){      //对每一个点进行深搜的条件是:  
                                   //1:不是障碍,2:没有被访问过   
            for(int j=1;j<=n;j++){ 
                if(maze[i][j]=='@'&& !visit[i][j]){visit[i][j]=1; dfs(i,j);sum++;} 
            } 
        } 
        cout<<sum<<endl; 

    } 

    return 0; 

} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值