1012. The Best Rank (25)

1012. The Best Rank (25)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output “N/A”.
Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

部分正确了无数遍= =,老是看不懂题目的意思。。心好累= =。。。后来膜拜了无数大神的帖子才有所触动。。。一直觉得代码好多重复,想写一份简单一些的。。后来发现是我的错T_T。。。是我想多了对不起 T_T

最后贴出AC的代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
#define maxn 2005
using namespace std;

struct student {
    string name;
    int c,m,e,a;
}ss[maxn];

bool cmp1(student x, student y){
    return x.a > y.a;
}
bool cmp2(student x, student y){
    return x.c > y.c;
}
bool cmp3(student x, student y){
    return x.m > y.m;
}
bool cmp4(student x, student y){
    return x.e > y.e;
}

int main()
{
    int n,m;
    cin>>n>>m;
    for(int i = 0;i < n;i ++)
    {
        cin>>ss[i].name>>ss[i].c>>ss[i].m>>ss[i].e;
        ss[i].a = (int)(ss[i].c+ss[i].m+ss[i].e)/3.0;
    }

    string tmp;
    for(int i = 0;i < m;i ++)
    {
        getchar();
        cin>>tmp;
        int f=0,j;
        for(j = 0;j < n;j ++)
        {
            if(ss[j].name == tmp) {f=1;break;}
        }
        if(!f) {printf("N/A\n");continue;}
        int rank1,rank2,rank3,rank4;
        sort(ss,ss+n,cmp1);
        for(int k = 0;k < n;k ++)
        {
            if(ss[k].name == tmp)
            {
                rank1 = k;
                int tt = k - 1;
                while (tt >= 0){
                    if (ss[k].a == ss[tt].a)
                        rank1 = tt;
                    tt--;
                }
                break;
            }
        }
        sort(ss,ss+n,cmp2);
        for(int k = 0;k < n;k ++)
        {
            if(ss[k].name == tmp)
            {
                rank2 = k;
                int tt = k - 1;
                while (tt >= 0){
                    if (ss[k].c == ss[tt].c)
                        rank2 = tt;
                    tt--;
                }
                break;
            }
        }
        sort(ss,ss+n,cmp3);
        for(int k = 0;k < n;k ++)
        {
            if(ss[k].name == tmp)
            {
                rank3 = k;
                int tt = k - 1;
                while (tt >= 0){
                    if (ss[k].m == ss[tt].m)
                        rank3 = tt;
                    tt--;
                }
                break;
            }
        }
        sort(ss,ss+n,cmp4);
        for(int k = 0;k < n;k ++)
        {
            if(ss[k].name == tmp)
            {
                rank4 = k;
                int tt = k - 1;
                while (tt >= 0){
                    if (ss[k].e == ss[tt].e)
                        rank4 = tt;
                    tt--;
                }
                break;
            }
        }
        //输出排名最高的单科或平均分的名次,并输出该科目。
        if ((rank1 <= rank2) && (rank1 <= rank3) && (rank1 <= rank4)){
            cout << rank1+1 << " " << "A" << endl;
        }
        else if ((rank2 < rank1) && (rank2 <= rank3) && (rank2 <= rank4)){
            cout << rank2+1 << " " << "C" << endl;
        }
        else if ((rank3 < rank1) && (rank3 < rank2) && (rank3 <= rank4)){
            cout << rank3+1 << " " << "M" << endl;
        }
        else{
            cout << rank4+1 << " " << "E" << endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值