Hdu 4341 Gold miner

Gold miner

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1033    Accepted Submission(s): 424


Problem Description
Homelesser likes playing Gold miners in class. He has to pay much attention to the teacher to avoid being noticed. So he always lose the game. After losing many times, he wants your help.

To make it easy, the gold becomes a point (with the area of 0). You are given each gold's position, the time spent to get this gold, and the value of this gold. Maybe some pieces of gold are co-line, you can only get these pieces in order. You can assume it can turn to any direction immediately.
Please help Homelesser get the maximum value.
 

Input
There are multiple cases.
In each case, the first line contains two integers N (the number of pieces of gold), T (the total time). (0<N≤200, 0≤T≤40000)
In each of the next N lines, there four integers x, y (the position of the gold), t (the time to get this gold), v (the value of this gold). (0≤|x|≤200, 0<y≤200,0<t≤200, 0≤v≤200)
 

Output
Print the case number and the maximum value for each test case.
 

Sample Input
  
  
3 10 1 1 1 1 2 2 2 2 1 3 15 9 3 10 1 1 13 1 2 2 2 2 1 3 4 7
 

Sample Output
  
  
Case 1: 3 Case 2: 7
 

Author
HIT
 

Source
 

Recommend
zhuyuanchen520

先预处理下后用分组背包解题预处理:假设具有相同斜率的坐标有x个,将其转化为一组物品,将离原点最近的坐标视为一个物品,

离原点最近的2个坐标也视为一个物品。。。。一直到x个。


#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>

int num[201][5];
int flag[201]; //用来标记物品属于哪个组
int f[40001]; //花费

int cmp(const void *a,const void *b)
{
    double tmp1=(double)(((int *)a)[0])/((int*)a)[1];
    double tmp2=(double)(((int *)b)[0])/((int*)b)[1];
    if(fabs(tmp1-tmp2)<0.000001)
    {
        return ((int*)a)[1]-((int*)b)[1];
    }
    else
        return tmp1>tmp2?1:-1;

}

int main(void)
{
    int N,T,t=0;
//    freopen("d:\\in.txt","r",stdin);
    while(scanf("%d%d",&N,&T)==2)
    {
        int i,j,k,max=0;
        t++;
        for(i=0;i<N;i++)
        {
            scanf("%d%d%d%d",&num[i][0],&num[i][1],&num[i][2],&num[i][3]);
            max+=num[i][2];
        }
        qsort(num,N,sizeof(num[0]),cmp);    //将具有相同斜率的坐标放在了一起,且离原点越近,排在越前
        memset(flag,0,sizeof(flag));
        int count=1;
        flag[0]=1;
        for(i=1;i<N;i++)              //对物品进行分组,且预处理物品组
        {
            double tmp1=(double)num[i-1][0]/num[i-1][1];
            double tmp2=(double)num[i][0]/num[i][1];
            if(fabs(tmp1-tmp2)<0.000001)
            {
                num[i][2]+=num[i-1][2];
                num[i][3]+=num[i-1][3];
            }
            else
                count++;
            flag[i]=count;
        }
        j=0;
        memset(f,0,sizeof(f));
        for(k=1;k<=count;k++)       //分组背包
        {
            for(i=T;i>=1;i--)
            {
                int tmp=j;
                while(flag[tmp]==k)
                {
                    if(i-num[tmp][2]>=0)
                        f[i]=f[i]>f[i-num[tmp][2]]+num[tmp][3]?f[i]:f[i-num[tmp][2]]+num[tmp][3];
                    tmp++;
                }
            }
            while(flag[j]==k)
                j++;
        }
        printf("Case %d: %d\n",t,f[T]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总分析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的医院后台管理系统实现了病房管理、病例管理、处方管理、字典管理、公告信息管理、患者管理、药品管理、医生管理、预约医生管理、住院管理、管理员管理等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让医院后台管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值