Poj 1837 Balance

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7628 Accepted: 4609

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source

Romania OI 2002


一个求多少种方案的分组背包问题可以按求01背包问题一样的方法来求,用数组存下存在的路径条数,然后DP

只是其中多了求分组背包的思想

f[i][j]表示前i个砝码到j的路径条数,j为所有砝码与坐标的乘积之和

所求的方案数即为f[G][7500];(正常理解应为f[G][0],不过由于j存在负数,对区间进行了映射,由[-7500,7500]映射到[0,15000]

由于分组背包下的同组物品需要同时处理,而砝码与坐标的乘积可能为正也可能为负,所以不能用滚动数组实现(我的理解)。



#include<stdio.h>
#include<string.h>

int c[21],v[21];

int f[21][15001];

int main(void)
{
	int C,G;
//	freopen("d:\\in.txt","r",stdin);
	while(~scanf("%d%d",&C,&G))
	{
		int i,j,k;
		for(i=1;i<=C;i++)
			scanf("%d",&c[i]);
		for(i=1;i<=G;i++)
			scanf("%d",&v[i]);
		memset(f,-1,sizeof(f));
		f[0][7500]=1;              //没有砝码的时候两边相等的路径为1,即什么也不放
		for(i=1;i<=G;i++)
		{
			for(j=15000;j>=0;j--)
			{
				for(k=1;k<=C;k++)
				{
					if(j-v[i]*c[k]>=0 && j-v[i]*c[k]<=15000 &&f[i-1][j-v[i]*c[k]]!=-1)
					{
						f[i][j]=f[i][j]==-1?f[i-1][j-v[i]*c[k]]:f[i-1][j-v[i]*c[k]]+f[i][j];
					}
				}
			}
		}
		printf("%d\n",f[G][7500]);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值