Hdu 2665 Kth number

本文介绍了一种解决区间查找第K大数的问题,并提供了一个具体实现案例。该算法使用了划分树的数据结构,时间复杂度为O(nlog(n) + mlog(n)),空间复杂度为O(nlog(n)),适用于大规模数据处理。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Kth number

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2301    Accepted Submission(s): 782


Problem Description
Give you a sequence and ask you the kth big number of a inteval.
 

Input
The first line is the number of the test cases.
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere.
The second line contains n integers, describe the sequence.
Each of following m lines contains three integers s, t, k.
[s, t] indicates the interval and k indicates the kth big number in interval [s, t]
 

Output
For each test case, output m lines. Each line contains the kth big number.
 

Sample Input
  
  
1 10 1 1 4 2 3 5 6 7 8 9 0 1 3 2
 

Sample Output
  
  
2
 

Source
 

Recommend
zty

 划分树

时间复杂度O( nlog(n) mlog(n)     n代表数据元素个数,m代表操作次数

空间复杂度O( nlog(n))


#include<stdio.h>
#include<algorithm>
using namespace std;

#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define MAXN 110000

int sorted[MAXN];
int val[20][MAXN];
int toL[20][MAXN];
int n,m;

void build(int l,int r,int rt,int d)
{
    if(l==r)
    {
        return ;
    }
    int i,count,mid=(l+r)>>1;
    int tmp=sorted[mid];
    count=mid-l+1;
    for(i=l;i<=r;i++)
    {
        if(val[d][i]<tmp)
            count--;
    }
    int lpos=l,rpos=mid+1;
    toL[d][0]=0;
    for(i=l;i<=r;i++)
    {
        if(val[d][i]<tmp)
        {
            val[d+1][lpos++]=val[d][i];
            toL[d][i]=toL[d][i-1]+1;
        }
        else if(val[d][i]>tmp)
        {
            val[d+1][rpos++]=val[d][i];
            toL[d][i]=toL[d][i-1];
        }
        else if(count>0)
        {
            val[d+1][lpos++]=val[d][i];
            toL[d][i]=toL[d][i-1]+1;
            count--;
        }
        else
        {
            val[d+1][rpos++]=val[d][i];
            toL[d][i]=toL[d][i-1];
        }

    }
    build(lson,d+1);
    build(rson,d+1);
}

int query(int L,int R,int k,int l,int r,int rt,int d)
{
    if(l==r)
        return val[d][L];
    int s1;
    int s2;
    if(L!=l)
    {
        s1=toL[d][R]-toL[d][L-1];
        s2=toL[d][L-1]-toL[d][l-1];
    }
    else
    {
        s1=toL[d][R]-toL[d][L-1];
        s2=0;
    }
    int new_L,new_R;
    int mid=(l+r)>>1;
    if(k<=s1)
    {
        new_L=l+s2;
        new_R=l+s1+s2-1;
        return query(new_L,new_R,k,lson,d+1);
    }
    else
    {
        k=k-s1;
        s1=(R-L+1)-s1;
        s2=L-l-s2;
        new_L=(mid+1)+s2;
        new_R=(mid+1)+s1+s2-1;
        return query(new_L,new_R,k,rson,d+1);
    }

}
int main(void)
{
//    freopen("d:\\in.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        int i;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&val[0][i]);
            sorted[i]=val[0][i];
        }
        sort(sorted+1,sorted+1+n);
        build(1,n,1,0);
        int a,b,k;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&k);
            printf("%d\n",query(a,b,k,1,n,1,0));
        }
    }
    return 0;
}




在探索智慧旅游的新纪元中,一个集科技、创新与服务于一体的整体解决方案正悄然改变着我们的旅行方式。智慧旅游,作为智慧城市的重要分支,旨在通过新一代信息技术,如云计算、大数据、物联网等,为游客、旅游企业及政府部门提供无缝对接、高效互动的旅游体验与管理模式。这一方案不仅重新定义了旅游行业的服务标准,更开启了旅游业数字化转型的新篇章。 智慧旅游的核心在于“以人为本”,它不仅仅关注技术的革新,更注重游客体验的提升。从游前的行程规划、信息查询,到游中的智能导航、个性化导览,再到游后的心情分享、服务评价,智慧旅游通过构建“一云多屏”的服务平台,让游客在旅游的全过程中都能享受到便捷、个性化的服务。例如,游客可以通过手机APP轻松定制专属行程,利用智能语音导览深入了解景点背后的故事,甚至通过三维GIS地图实现虚拟漫游,提前感受目的地的魅力。这些创新服务不仅增强了游客的参与感和满意度,也让旅游变得更加智能化、趣味化。 此外,智慧旅游还为旅游企业和政府部门带来了前所未有的管理变革。通过大数据分析,旅游企业能够精准把握市场动态,实现旅游产品的精准营销和个性化推荐,从而提升市场竞争力。而政府部门则能利用智慧旅游平台实现对旅游资源的科学规划和精细管理,提高监管效率和质量。例如,通过实时监控和数据分析,政府可以迅速应对旅游高峰期的客流压力,有效预防景区超载,保障游客安全。同时,智慧旅游还促进了跨行业、跨部门的数据共享与协同合作,为旅游业的可持续发展奠定了坚实基础。总之,智慧旅游以其独特的魅力和无限潜力,正引领着旅游业迈向一个更加智慧、便捷、高效的新时代。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值