数据结构实验之二叉树的建立于遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

输入

  输入一个长度小于50个字符的字符串。

输出

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfacgefdba35

提示

 

来源

 ma6174

示例程序

 
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node 
{
    int data;
    struct  node *l,*r;
};
struct node *p;
int count=0;
struct node *creat(struct node *p)
{
    char ch;
    scanf("%c",&ch);
    if(ch==',')
        p=NULL;
    
    else 
    {
        p=(struct node *)malloc(sizeof(struct node));
        p->data=ch;
        p->l=creat(p->l);
        p->r=creat(p->r);
    }
    return p;
}
void zhongxu(struct node *p)
{
    if(p)
    {
        zhongxu(p->l);
        printf("%c",p->data);
        zhongxu(p->r);
    }
}
void houxu(struct node *p)
{
    if(p)
    {
        houxu(p->l);
        houxu(p->r);
        printf("%c",p->data);
    }
}
int jiedian(struct node *p)
{
    if(p)
    {
        if((p->l==NULL)&&(p->r==NULL))
            count++;
        jiedian(p->l);
        jiedian(p->r);
    }
    return 0;
}
int deep(struct node *p)
{
    int l1,r1;
    if(!p)
        return 0;
    l1=deep(p->l);
    r1=deep(p->r);
    return l1>r1?l1+1:r1+1;
}
int main()
{
    struct node *root;
    root=creat(p);
    zhongxu(root);
    printf("\n");
    houxu(root);
    printf("\n");
    jiedian(root);
    printf("%d\n",count);
    printf("%d\n",deep(root));
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值