数据结构实验之栈三:后缀式求值

Time Limit: 1000MS Memory limit: 65536K

题目描述

对于一个基于二元运算符的后缀表示式(基本操作数都是一位正整数),求其代表的算术表达式的值。

输入

输入一个算术表达式的后缀式字符串,以‘#’作为结束标志。

输出

求该后缀式所对应的算术表达式的值,并输出之。

示例输入

59*684/-3*+#

示例输出

57

提示

基本操作数都是一位正整数!
#include<iostream>
#include<string>
#include<stack>
#include<stdlib.h>
#include<stdio.h>
using namespace std;
int main()
{
    stack<int >q;
    char str[100];
    scanf("%s",str);
    for(int i=0;str[i]!='#';i++)
    {
        if(str[i]>='0'&&str[i]<='9')
            q.push(str[i]-48);
        else 
        {
            if(str[i]=='+')
            {
                int a=q.top();
                q.pop();
                int b=q.top();
                q.pop();
                int c=a+b;
                q.push(c);
            }
            if(str[i]=='-')
            {
                int a=q.top();
                q.pop();
                int b=q.top();
                q.pop();
                int c=b-a;
                q.push(c);
            }
             if(str[i]=='*')
            {
                int a=q.top();
                q.pop();
                int b=q.top();
                q.pop();
                int c=a*b;
                q.push(c);
            }
             if(str[i]=='/')
            {
                int a=q.top();
                q.pop();
                int b=q.top();
                q.pop();
                int c=b/a;
                q.push(c);
            }
        }
    }
    printf("%d\n",q.top());
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值