Largest Rectangle in a Histogram (dp思想找最大区间)

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

 


Input The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line. Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题意:找矩形最大面积

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define MT(a,b) memset(a,b,sizeof(a))
#define ll long long
const int maxn = 1e5+5;
const int ONF = -0x3f3f3f3f;
const int INF = 0x3f3f3f3f;
const int N = 1e3+5;

ll  a[maxn];
int l[maxn];//记录左边最远不小于a[i]下标
int r[maxn];//记录右边最远不小于a[i]下标
            //使得闭区间[l[i],r[i]]所有元素大于等于a[i]
int main()
{
    int n;
    while(cin>>n&&n)
    {
        MT(a,0);MT(l,0);MT(r,0);
        a[0]=a[n+1]=ONF;//因为记录a[i]两边最远不小于a[i]的区间,所以a[0]和a[n+1]赋值最小
        for(int i=1;i<=n;i++)
        {
            scanf("%I64d",&a[i]);
            l[i]=r[i]=i;//区间初始化
        }
        for(int i=1,j=n;i<=n;i++,j--)
        {
            while(a[i]<=a[l[i]-1])l[i]=l[l[i]-1];
                           //因为第i点的左区间由i点前面L数组转移的得来所以就正向遍历
            while(a[j]<=a[r[j]+1])r[j]=r[r[j]+1];
                           //反之第i点的右区间由i点后面r数组转移的得来所以就反向遍历
        }
        ll ans = 0;
        for(int i=1;i<=n;i++) ans=max(ans, a[i]*(r[i]-l[i]+1));
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值