Coins (混合背包)

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output
For each test case output the answer on a single line.

Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4

题意:价值为Ai的物品有Ci个,问选取其中任意物品组成小于m的价值,问这样的价值最多有多少个

//1563ms暴力飘过,混合背包的方法网上有很多就不写了
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define MT(a,b) memset(a,b,sizeof(a))
#define ll long long
const int maxn = 2e5+5;
const int ONF = 0x3f3f3f3f;
const int INF = -0x3f3f3f3f;
const int N = 1e3+5;

int main()
{
    int l=0;
    while(!0)
    {
        int n,p;cin>>n>>p;
        if(!(n+p))break;
        int a[N],num[N];
        MT(a,0);MT(num,0);
        int cnt=0;
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        for(int i=0;i<n;i++)scanf("%d",&num[i]);
        int f[maxn];MT(f,0);
        f[0]=1;
        int ans = 0;
        for(int i=0;i<n;i++)
        {
            int che[maxn];MT(che,0);
            for(int j=a[i];j<=p;j++)
            {
                if(f[j-a[i]]&&!f[j])
                {
                    if(che[j-a[i]]<num[i])
                    {
                        ans++;
                        f[j]=f[j]|f[j-a[i]];
                        che[j]=che[j-a[i]]+1;
                    }
                }
            }
        }
        cout<<ans<<endl;
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值