Taxi Cab Scheme(不可重复利用最小路径覆盖)

Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible, there is also a need to schedule all the taxi rides which have been booked in advance. Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides. 

For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest, at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight. 

Input

On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time. 

Output

For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides. 

Sample Input

2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11

Sample Output

1
2

题意:有n个人要坐taxi, 给出每个人的上车时刻,起点和终点,每个人必须在上车时刻前一分钟上车,问最小需要多少辆车。距离为曼哈顿距离,每单位距离需要一分钟时间。

题解:建图,若taxi跑完A后还能跑B则建边A->B,然后跑一个最小路径覆盖(有向图的最小路径覆盖 = n - 拆点后的最大匹配)

AC代码

//#include"bits/stdc++.h"
//#include<unordered_map>
//#include<unordered_set>
#include<iostream>
#include<sstream>
#include<iterator>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<bitset>
#include<climits>
#include<queue>
#include<iomanip>
#include<cmath>
#include<stack>
#include<map>
#include<ctime>
#include<new>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
#define lson l, mid, node<<1
#define rson mid + 1, r, node<<1|1
#define Root 1, m, 1
#define Node l, r, node
const int INF  =  0x3f3f3f3f;
const int O    =  1e6;
const int mod  =  20071027;
const int maxn =  1e3 + 5;
const double PI  =  acos(-1.0);
const double E   =  2.718281828459;

int head[maxn], cnt;
struct dd { int to, next; } e[maxn * maxn];
void add(int u, int v) { e[cnt].to = v; e[cnt].next = head[u]; head[u] = cnt ++; }

int n, lx[maxn], ly[maxn], vis[maxn];
void init() { MT(lx, -1); MT(ly, -1); MT(head, -1); cnt = 0; }

bool dfs(int u){
    for(int i=head[u]; i!=-1; i=e[i].next){
        int v = e[i].to;
        if(vis[v]) continue;
        vis[v] = 1;
        if(ly[v] == -1 || dfs(ly[v])) {
            lx[u] = v; ly[v] = u;
            return true;
        }
    }
    return false;
}

struct Lin { int h, m, x1, y1, x2, y2; } l[maxn];

bool check(int i, int j) {
    int t = (l[j].h - l[i].h) * 60 + (l[j].m - l[i].m);
    int len1 = (abs(l[i].x1 - l[i].x2) + abs(l[i].y1 - l[i].y2));
    int len2 = (abs(l[i].x2 - l[j].x1) + abs(l[i].y2 - l[j].y1));
    return t - len1 - len2 >= 1;
}

int main(){
    int T; scanf("%d", &T);
    while( T --) {
        init(); scanf("%d", &n);
        for(int i=0; i<n; i++) scanf("%d:%d %d%d%d%d", &l[i].h, &l[i].m, &l[i].x1, &l[i].y1, &l[i].x2, &l[i].y2);
        for(int i=0; i<n; i++) for(int j=0; j<n; j++) {
            if(i != j && check(i, j)) add(i<<1, j<<1|1); // make map
        }
        int ans = 0;
        for(int i=0; i<n<<1; i++) { MT(vis, 0); ans += dfs(i); } // hungry
        printf("%d\n", n - ans); // 有向图的最小路径覆盖 = n - 拆点后的最大匹配
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值