Large Division LightOJ - 1214 (同余定理)

点击打开链接


Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible


题意:判断一个大数是否能被整除。

题解:利用同余定理判断余数是否为0,若为0,则能被整除。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define N 1000
using namespace std;

char a[N];
int main(){
	int t,k=1;
	long long n;
	cin>>t;	
	while(t--){
	long long ans=0;
		cin>>a;
		cin>>n;
		int m=strlen(a);
		if(a[0]=='-'){			
			for(int i=1;i<m;i++){	
				ans=((ans*10+(a[i]-'0'))%n);		
			}
		}
		else{
			for(int i=0;i<m;i++){	
				ans=((ans*10+(a[i]-'0'))%n);		
			}
		}
		if(ans==0)
		cout<<"Case "<<k++<<": "<<"divisible"<<endl;
		else
		cout<<"Case "<<k++<<": "<<"not divisible"<<endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值