POJ - 3061 Subsequence(前缀和+二分和尺取法)


Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

 Status

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3


题意:给定长度为n的整数数列a0,a1,…,an-1以及整数S。求出总和不小于S的连续子序列的长度的最小值。如果解不存在,输出0。

思路:

1. 可以用O(n)的时间算好前缀和,之后就能在O(1)的时间计算区间上的总和。在确定起点s后,二分快速找出使得序列和不小于S的最近的终点就好了。算法复杂度是O(nlogn).

2. 第二种方法是利用尺取法求解:

(1).以s=t=sum=0初始化。

(2).只要依然有sum<S,就将sum增加ai,并将t增加1。

(3).如果(2)中无法满足sum>=S则终止。否则的话,更新res=min(res,t-s).

(4).将sum减去as,s增加1后回到(2).

算法的复杂度是O(n)。


前缀和+二分搜索

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

int a[100100];

int main(){
	int T;
	cin>>T;
	while(T--){
		int n,s;
		cin>>n>>s;
		for(int i=0;i<n;i++){
			cin>>a[i];
			a[i]=a[i-1]+a[i];
		}
		if(a[n-1]<s)
		cout<<"0"<<endl;
		else{
			int ans=n;
			for(int i=0;a[i]+s<=a[n-1];i++){
				int d=lower_bound(a+i,a+n,a[i]+s)-a;
				ans=min(ans,d-i);
			}
			cout<<ans<<endl;
		} 
	}
	return 0;
}


//#include<iostream>
//#include<algorithm>
//#include<cstring>
//using namespace std;
//
//int a[100500]; 
//
//bool cmp(int a,int b){
//	return a>b;
//}
//
//int main(){
//	int T;
//	cin>>T;
//	while(T--){
//		memset(a,0,sizeof(a));
//		int n,s;
//		cin>>n>>s;
//		for(int i=0;i<n;i++)
//		cin>>a[i];
//		sort(a,a+n,cmp);
//		//n=unique(a,a+n)-a;
//		int ans=a[0];
//		int flag=1;
//		for(int i=1;i<n;i++){
//			if(ans>=s){
//				cout<<i<<endl;
//				flag=0;
//				break;
//			}
//			ans+=a[i];
//		} 
//		if(flag)
//		cout<<"0"<<endl;
//	}
//	return 0;
//}

尺取法:

#include<cstdio>
#include<cstring>
using namespace std;

#define min(a,b) a<b?a:b
const int MAXN = 100000 + 1000;
int num[MAXN];
int n, S;

int main()
{
	int casen;
	scanf("%d", &casen);
	while (casen--)
	{
		scanf("%d%d", &n, &S);
		for (int i = 0; i < n; i++)
			scanf("%d", &num[i]);
		int ret = n + 1;
		int s = 0, t = 0, sum = 0;
		for (;;)
		{
			while (t < n && sum < S)
				sum += num[t++];
			if (sum < S) break;
			ret = min(ret, t - s);
			sum -= num[s++];
		}

		if (ret>n)
			ret = 0;

		printf("%d\n", ret);
	}
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值