【POJ 2407】Relatives(欧拉函数-水题)


点击打开题目


Relatives
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14862 Accepted: 7467

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

Source



题意:找出在1~n 之间有几个与n互素的数。
题解:直接套欧拉函数模板。

代码:
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int Eular(int n)  
{  
    int ans=1;  
    for (int i=2;i<=sqrt((double)n);i++)  
    {  
        if (n%i==0)  
        {  
            n/=i;  
            ans*=(i-1);  
            //若n有个因子是i的k次,根据欧拉公式有下面的代码  
            while (n%i==0)   
            {  
                n/=i;  
                ans*=i;  
            }  
        }  
    }  
    if (n>1)     //若最后剩的数为大于5的素数,根据欧拉公式再算进去   
        ans*=(n-1);  
    return ans;  
} 
int main(){
	int n;
	while(cin>>n&&n){
		int ans=1;
		if(n>2)
		cout<<Eular(n)<<endl;
		else
		cout<<"0"<<endl;
	}
	
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值