【HDU1022】Train Problem I(栈-好题)

题目

                        Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38535 Accepted Submission(s): 14491

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.

Sample Input
3 123 321
3 123 312

Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint
Hint

For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.”.

Author
Ignatius.L

题意:
给出第一个数字序列,利用栈的操作,变换为第二个数字序列,输出每一步的操作,最后输出“finish”。

题解:
火车进站后则入栈,与出站顺序相比较,如果栈顶元素等于当前出站顺元素,则退栈,出站数+1。这样循环,直到栈顶元素不等于出站元素为止,继续火车进站即可。
如果全部进站并处理后,栈为空,则说明出站顺序可以满足。

代码:

#include<iostream>
#include<stack>
#include<algorithm>
#include<cstring>
using namespace std;
int main(){
    int n;
    char str1[200],str2[200];
    int flag[200];
    while(cin>>n>>str1>>str2){
        int i=0,k=0;
        memset(flag,-1,sizeof(flag));//记录入栈出栈
        stack<char> sta;
        sta.push(str1[i]);
            flag[k++]=1;
        for(int j=0;j<n;){
            if(!sta.empty()&&sta.top()==str2[j]){//判断栈是否为空,且栈顶元素是否等于第二个数字序列
                sta.pop();//找到相同的去除栈顶元素
                flag[k++]=0;//标记为出栈
                j++;//相等的话,str2下标向后移动一位
            }else{
                if(i==n)
                break;
                else{
                    sta.push(str1[++i]);
                    flag[k++]=1;//1代表入栈
                }
            }
        }
        if(i==n){//把栈全部比较后仍然没有结果输出“No”
                cout<<"No."<<endl;
            }else{
                cout<<"Yes."<<endl;
                for(int i=0;i<k;i++){
                    if(flag[i]==1)
                    cout<<"in"<<endl;
                    else
                    cout<<"out"<<endl;
                }
            }
            cout<<"FINISH"<<endl;
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值