【POJ 3041 】Asteroids (匈牙利算法最小点覆盖&二分图)

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

题意给出一个N*N的矩阵,有的位置有行星。已知一枪可以击溃一行或一列上的所有行星。问最少多少枪可以击溃       所有的行星。

思路:以行作为X集合,以列作为Y集合,一个行星在(x,y),则x对应X中的点向y对应Y中的点连一条边,则某个顶点一       旦被选,则与之相连的边(也就是行星)都会被选,也就是选出最少的顶点覆盖所有的边,即最小顶点覆盖。

算法:

      Konig定理:一个二分图中的最大匹配数等于这个图中的最小点覆盖数。

      最小点覆盖数:假如选中了一个点就相当于覆盖了以它为端点的所有边,你需要选择最少的点覆盖所有的边。

PS:模板题目,直接套用匈牙利算法求最大的匹配数的模板即可。关键是理解如何建图。


代码:


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int MAX=1e3+10;

bool relationship[MAX][MAX];
bool vis[MAX];
int partner[MAX];
int k,m,n;

bool find(int f){
	for(int i=1;i<=m;i++){
		int v=i;
		if(relationship[f][v]&&!vis[v]){
			vis[v]=true;
			if(partner[v]<0||find(partner[v])){
				partner[v]=f;
				return true;
			}
		}
	}
	return false;
}

int main(){
	while(cin>>m>>n){
		int x,y;
		memset(partner,-1,sizeof(partner));
		memset(relationship,false,sizeof(relationship));
		for(int i=0;i<n;i++){
			scanf("%d %d",&x,&y);
			relationship[x][y]=true;
		}
		int ans=0;
		for(int i=1;i<=m;i++){
			memset(vis,false,sizeof(vis));
			if(find(i))
			ans++;
		}
		cout<<ans<<endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值