Word Reversal

点击打开题目


Word Reversal

Time Limit: 2 Seconds       Memory Limit: 65536 KB

For each list of words, output a line with each word reversed without changing the order of the words.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.


Output

For each test case, print the output on one line.


Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest


Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc


Source:  East Central North America 1999, Practice


出了六次:Segmentation Fault:分隔错误

数组别开太大,注意输出格式:

Ac代码:


#include<bits/stdc++.h>
using namespace std;

const int MAX=1e4+10;

string ss[MAX];
char s[MAX];

int main(){
	int n;cin>>n;
	while(n--){
	
			int m;
			cin>>m;
			getchar();
			for(int i=0;i<m;i++){
				gets(s);
				ss[i]=s;
				//cout<<ss[i]<<endl;
			}
			stack<string>sta;
			string strt;
			for(int i=0;i<m;i++){
				//int t=strlen(s[i]);
				for(int j=ss[i].length()-1;j>=0;j--){
					if(ss[i][j]!=' '){
						strt+=ss[i][j];
					}
					else{
						sta.push(strt);
						strt.clear();
					}
					if(j==0){
						sta.push(strt);
						strt.clear();
					}
				}
				cout<<sta.top();
				sta.pop();
				while(!sta.empty()){
					cout<<" "<<sta.top();
					sta.pop();	
				}
				cout<<endl;
			}
		if(n!=0)
		cout<<endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值