hdu 1113

Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
 

Input
The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

Sample Input
  
  
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
 

Sample Output
  
  
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******


读入一个字典,如果给出的字符串能用字典中的一个字符串通过重新排序表示,输出该字符串,不过需要注意要对字典进行排序。

#include<bits/stdc++.h>
using namespace std;
char ss,a[5000],s[105][100000];
map<char,int> c;
map<char,int> d;
struct foo { char aa[sizeof(*s)/sizeof(**s)]; bool operator<( const foo& rhs ) const { return strcmp(aa,rhs.aa)<0; } };
//多亏了知乎上的大神,才知道对二维数组的排序要用结构体封装才能排,QAQ.
int dicsum,cnt,len1,len2,i,j,flag;
int main(){
    dicsum=0;
    while(cin>>a){
       if(strcmp(a,"XXXXXX")==0)break;
       strcpy(s[++dicsum],a);
       }//将一开始的字符串放到字典中
   sort( (foo*)(s+1), (foo*)(s+dicsum+1) );//输出是要按字典序输出,没这一步会WA
    while(cin>>a){
         if(strcmp(a,"XXXXXX")==0)break;
         cnt=0;
         len1=strlen(a);
         for(i=1;i<=dicsum;i++)
         {
          len2=strlen(s[i]);
          if(len1==len2)
          {
            flag=1;
            for(ss='a';ss<='z';ss+=1){c[ss]=d[ss]=0;}//map并不能用memset,好姜
            for(j=0;j<len1;j++)c[s[i][j]]+=1;
            for(j=0;j<len1;j++)d[a[j]]+=1;
            for(ss='a';ss<='z';ss+=1)
            if(c[ss]!=d[ss]){flag=0;break;}//必须满足两个字符串每一个字符的数量都相同,才输出
            if(flag){cout<<s[i]<<endl;cnt++;}
          }
         }//对每一个字符串查找字典所有串
         if(cnt==0)cout<<"NOT A VALID WORD"<<endl;
         cout<<"******"<<endl;}
         return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值