ZJU-PAT 1050

#include<iostream>
#include<string>
using namespace std;

/*
Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
*/

bool myhash[150];

string s1,s2;

void run()
{
  getline(cin,s2);

  int i;
  string s="";
  int len=s1.size();
  int len2=s2.size();

  for(i=0;i<150;i++) myhash[i]=0;

  for(i=0;i<len2;i++) 
  {
    myhash[s2[i]]=1;
  }
  
  
  for(i=0;i<len;i++)
  {
    if(myhash[s1[i]]==0) s+=s1[i];
  }
  cout<<s<<endl;
}

int main()
{
  while(getline(cin,s1)) run();
  return 0;
}

PAT 1050:String Subtraction

利用ascii表的哈希去重

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值