POJ 1979 - Red and Black

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 34958 Accepted: 18918

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

POJ 1979

解体思路

深度优先遍历

代码

 #include <iostream>
 
 #define M  20 + 10
 #define N  20 + 10
 using namespace std;

 int m, n;
 int count;
 char map[M][N];
 int dir[4][2] = {{-1, 0},{1, 0},{0, 1},{0, -1}};
 
 void dfs(int x, int y)
 {
 	int newx, newy;
 	
 	map[x][y] = '#';
 	for(int i = 0; i < 4; i++)
 	{
 		newx = x + dir[i][0];
 		newy = y + dir[i][1];
 		if(newx >= 0 && newx < n && newy >= 0 && newy < m && map[newx][newy] == '.')
 		{
 			count ++;
 			dfs(newx, newy);
 		}
 	}
 }
 
 int main()
 {
 	int x = 0, y = 0;
 	int result = 0;
 	//freopen("input.txt","r",stdin);
 
 	while(scanf("%d%d", &m, &n) != EOF && m && n)
 	{
 		memset(map, 0, sizeof(map));
 		count = 1;
 		
 		for(int i = 0; i < n; i++)
 		{
 			scanf("%s", &map[i]);
 		}
 		
 		for(int i = 0; i < n; i++)
 		{
 			for(int j = 0; j < m; j++)
 			{
 				if(map[i][j]== '@'){
 					x = i;
 					y = j;
 					map[x][y] = '.';
 				}
 			}
 		}
 		dfs(x, y);
 		result = count;
 		cout <<result<<endl;
 	}
 	return 0;
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值