HDU_1241Oil Deposits解题报告



Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4309    Accepted Submission(s): 2479


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
      
      
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
      
      
0 1 2 2
解法类型:DFS
解题思路:DFS直接水过。
算法实现:
#include<stdio.h>
#include<string.h>
char grid[102][102]; //储存格子符号;
int vis[102][102]; //是否被访问过  访问过赋为0,没有赋为1;
void DFS(int x,int y)
{
 if(grid[x][y]=='*' || vis[x][y]==0)return;//如果是*或者访问过  直接返回不执行下面程序;
 //不是*且没有被访问过则执行下面程序;
 vis[x][y]=0;
 DFS(x-1,y-1);
 DFS(x-1,y);
 DFS(x-1,y+1);
 DFS(x,y-1);
 DFS(x,y+1);
 DFS(x+1,y-1);
 DFS(x+1,y);
 DFS(x+1,y+1);
 //连续的递归调用查找基于这个点的八个方位的所有点;
}
int main()
{
 //freopen("1.in","r",stdin);
 int m,n,i,j,count;
 while(scanf("%d %d",&n,&m)!=EOF && (n || m))
 {
  count=0;//每一次循环开始把count赋为0,;
  memset(vis,0,sizeof(vis));//为了方便边界的判断,在输入的数据外围加一层已访问过的点;
    for(i=1;i<=n;i++)
    {
   scanf("%s",grid[i]);
   for(j=m;j>=1;j--)
   {
    grid[i][j]=grid[i][j-1];//把数据向后移一位;
    vis[i][j]=1;//把所有输入的数据储存的位置从新赋值为0;
   }
    }
    for(i=1;i<=n;i++)//从第一个点开始搜索,一直搜索到最后一个点;
    {
     for(j=1;j<=m;j++)
     {
      if(vis[i][j]==1 && grid[i][j]=='@') //如果遇到没有访问过的点且这点的符号为@的就把count的值加一;
      { 
       count++;
       DFS(i,j);//找出和这一点所有相连的@点,并且标记为已经访问;
      }
     }
     
    }
   printf("%d\n",count);
 }
 return 0;
 }



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值