河南省第十届ACM省赛题解 F Binary to Prime

To facilitate the analysis of a DNA sequence, a DNA sequence is represented by a binary number. The group of DNA-1 has discovered a great new way . There is a certain correlation between binary number and prime number. Instead of using the ordinary decadic numbers, they use prime base numbers. Numbers in this base are expressed as sequences of zeros and ones similarly to the binary numbers, but the weights of bits in the representation are not powers of two, but the elements of the primes ( 2, 3, 5, 7,… ).
翻译:为方便 DNA序列的分析, DNA序列是由一个二进制数表示的 。对 DNA-1组发现了一个伟大的新方式。 有二进制数和素数之间有一定的相关性。而不是使用普通的十进制数字,他们利用原基数。在这座数字表示序列的0和1类似于二进制数的位,但 在表示权重不是2的幂,但元素的素数 (2,3,5,7,…)。
For example 01101 , ie. 2+5+7=14
Herefore, it is necessary to convert the binary number to the sum of prime numbers
翻译:因此,将二进制数转换为素数的和是必要的
输入
The input consists of several instances, each of them consisting of a single line. Each line of the input contains a 01 string, length of not more than 150. The end of input is not marked in any special way.
翻译:输入由多个实例组成,每个实例由一行组成。输入的每一行包含01个字符串,长度不超过150。输入端没有以任何特殊方式标记。
输出
For each test case generate a single line containing a single integer , The sum of the primes.
翻译:对于每个测试用例生成一行包含一个整数,素数的和。
样例输入
000010
0011
11001
样例输出
3
5
20
解题思路:素数打表

#include <iostream>
#include <bits/stdc++.h>

using namespace std;
int a[2000],p[155];
void Prime()//打表求150个素数
{
    memset(a,0,sizeof(a));
    a[0]=a[1] = 1;a[2] = 0;
    for(int i = 2; i *i <= 2000; i++)
    {
        if(!a[i]){
           for(int j = i+i; j <= 2000; j+=i)
                a[j] = 1;
        }
    }
    int k=0;
    for(int i =2;i <= 2000;i ++){
        if(a[i]==0)
        {
            p[k++] = i;
        }
        if(k>150)
            break;
    }
}
int main()
{
    string str;
    Prime();
    while(cin>>str)
    {
        int len = str.length();
        int sum = 0;
        for(int i=len-1;i >= 0;i--)//从后往前读
        {
            if(str[i]=='1')//找到为1的字符
            {
                sum += p[len - i -1];//将下标转换成1—len中并求和
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值