hud Rikka with Subset 2017 多校第五场 (背包)

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1−An and their sum is m. Then for each subset S of A, Yuta calculates the sum of S.

Now, Yuta has got 2n numbers between [0,m]. For each i∈[0,m], he counts the number of is he got as Bi.

Yuta shows Rikka the array Bi and he wants Rikka to restore A1−An.

It is too difficult for Rikka. Can you help her?

Input
The first line contains a number t(1≤t≤70), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104).

The second line contains m+1 numbers B0−Bm(0≤Bi≤2n).

Output
For each testcase, print a single line with n numbers A1−An.

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.

Sample Input
2
2 3
1 1 1 1
3 3
1 3 3 1

Sample Output
1 2
1 1 1
Hint

In the first sample, A is [1,2]. A has four subsets [],[1],[2],[1,2] and the sums of each subset are 0,1,2,3 . So B=[1,1,1,1]
题目大意:给你一个a数组,a数组中所有元素之和是m,b【i】表示0—m中a数组的子集和为i的总次数。如第一组测试样例,a数组的和为3且只有两个元素,所以a={1,2}它的子集有空集,{1},{2},{1,2},a的子集中所有元素之分别和为0,1,2,3,所以0,1,2,3出现的次数是1,所以b数组全为1.
解题思路:如果 B[i]是 B数组中除了 B[​0]以外第一个值不为 0 的位置,那么显然 i 就是 A 中的最小数。现在需要求出删掉 i后的 B 数组,过程大概是反向的背包,即从小到大让 B[j]-=B[j-i].
时间复杂度 O(nm).

#include <bits/stdc++.h>
typedef long long ll;
using namespace std;
ll b[10005];
int a[55];
int main()
{
    int T;scanf("%d",&T);
    while(T--){
        int n,m,k;
        scanf("%d %d",&n,&m);
        for(int i=0;i<=m;i++){
            scanf("%lld",&b[i]);
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
                if(b[j]!=0)
                {
                    k = j;break;
                }
            a[i] = k;
            for(int j = k;j<=m;j++)
                b[j] -= b[j-k];
        }
        printf("%d",a[1]);
        for(int i=2;i<=n;i++)
            printf(" %d",a[i]);
        printf("\n");

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值