Sum Problem
Problem Description
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.//只有无符号的需要显式定义,如果没有unsigned 标识,就是有符号的。
Sample Input1
100
Sample Output
1
5050
Author
DOOM III
#include <iostream>
using namespace std;
int main()
{
int a,n;
while(cin>>a)
{
int i=0;
while(a)
{
i=i+a;//i为从1到a的和
a--;
}
cout<<i<<endl;
cout<<endl;
}
return 0;
}