CSU-ACM2017寒假集训1B-简单二分和三分 HDU - 2141

C - Can you find it?
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO
题意概述:输入任意三个数组,再输入测试次数,每次分别输入一个数字,问能否从这三个数组中分别取一个数使他们的和等于你输入的数字。能则输出YES,否就输出NO。
解决方案:先将a,b两个数组的任意两个元素的和求出来放入另一个数组m中,再进行二分,与c中的元素进行相加然后再与你输入的数值进行比较即可。
一开始我是选择将C数组进行二分,然而因为m中的元素个数远远大于c中的元素个数,所以将c中元素进行二分就会显得作用没有那么明显,因此进行改进,选择将数组m进行二分。
源代码:

#include <iostream>
#include<stdio.h>
#include<algorithm>

using namespace std;
int a[100][100];
int main()
{
    int i,j,n,ans1=0,ans2=0;
    int ki,kj;
    while(scanf("%d",&n)&&n){
            ans1=0,ans2=0;
        for(i=0;i<n;i++)
        {
            int sum1=0;
            for(j=0;j<n;j++)
            {
                 scanf("%d",&a[i][j]);
                 sum1+=a[i][j];
            }
            if(sum1%2!=0)
            {
                ans1++;
                ki=i+1;
            }
        }
        for(i=0;i<n;i++)
        {
            int sum2=0;
            for(j=0;j<n;j++)
            {
                sum2+=a[j][i];
            }
            if(sum2%2==1)
            {
                ans2++;
                kj=i+1;
            }
        }
        if(ans1==1&&ans2==1)
            {
                printf("Change bit (%d,%d)\n",ki,kj);
            }
        else if(ans1==0&&ans2==0){
            printf("OK\n");
        }
        else
        {
            printf("Corrupt\n");
        }

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值