poj 3692 Kindergarten(二分图匹配,最大独立集)

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
 

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.
 

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
 

Sample Input

    
    
2 3 3 1 1 1 2 2 3 2 3 5 1 1 1 2 2 1 2 2 2 3 0 0 0
 

Sample Output

Case 1: 3
Case 2: 4
 
独立集:任意两点都不相连的顶点的集合   

独立数:独立集中顶点的个数   

完全子图:任意两点都相连的顶点的集合   

最大完全数:最大完全子图中顶点的个数   

最大完全数=原图的补图的最大独立数   

最大独立数=顶点数-最大匹配数   

 

本题是要求图中的最大完全子图(最大团)中顶点的个数。   

由于原图的补图是一个二分图,其最大完全数等价于其补图的最大独立集中元素的个数,   

于是可以根据二分图的性质求出这个最大独立集。而普通图的最大团则是一个NP问题。   

 反过来建图,建立不认识的图,就变成求最大独立集了。

 


#include<iostream>
#include<string.h>
using namespace std;
int G,B,M;
int map[210][210],visited[210],p[210];
bool findpath(int x)
{
    for(int i=1;i<=B;i++)
    {
        if(!visited[i]&&map[x][i]==1)
        {
            visited[i]=1;
            if(!p[i]||findpath(p[i]))
            {
                p[i]=x;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int cases=1;
    while(cin>>G>>B>>M)
    {
        if(G==0&&B==0&&M==0)
            break;
        int i,j,x,y,sum=0;
        for(i=0;i<=G;i++)
            for(j=0;j<=B;j++)
                map[i][j]=1;
        memset(p,0,sizeof(p));
        for(i=1;i<=M;i++)
        {
            cin>>x>>y;
            map[x][y]=0;
        }
        for(i=1;i<=G;i++)
        {
            memset(visited,0,sizeof(visited));
            if(findpath(i))
                sum++;
        }
        sum=G+B-sum;
        cout<<"Case "<<cases++<<": "<<sum<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值