UVA 11300 Spreading the Wealth

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4
首先每个人的金币数量等于金币总数除以人数n,我们用M来表示。我们要注意每个人只能给左右相邻的人金币。
假设有四个人,编号1-4。设编号为i的人初始时有Ai个金币,对于1号来说,他给4号x1枚又得到2号给的x2枚,所以1号有
A1-x1+x2=M。类似的对于2号来说有A2-x2+x3=M 。。。。一直到An-xn+x1=M。这里有n个方程但可惜不能直接解方程组,我们尝试用x1依次表示出其他的xi,则本题就变成了单变量的极值问题。
A1-x1+x2=M -》x2=M-A1+x1=x1-c1(规定c1=A1-M)
A2-x2+x3=M -》x3=M-A2+x2=x1-c2
A3-x3+x4=M -》x4=M-A3+x3=x1-c3
我们希望所有xi的绝对值之和尽量小|x1| + |x2| + |x3| +。。+ |xn|要最小,注意|x1-ci|在几何意义上表示数轴上点x1到ci的距离,所以问题变成了给定数轴上的n个点,找出一个到他们的距离之和尽量小的点。不难猜到这个x1就是n个数经排序以后的中位数

#include <iostream>
#include <math.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
long long A[1000010],C[1000010],tot=0,M;
int main()
{
    int n;
    while(cin>>n)
    {
       tot=0;
       for(int i=1;i<=n;i++)
       {
           scanf("%lld",&A[i]);
           tot=tot+A[i];
       }
       M=tot/n;
       C[0]=0;
       for(int i=1;i<n;i++)
        C[i]=C[i-1]+M-A[i];
       sort(C,C+n);
       long long x1=C[n/2],ans=0;
       for(int i=0;i<n;i++)
         ans=ans+fabs(x1-C[i]);
       printf("%lld\n",ans);
    }
    return 0;
}
 

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值