算法入门经典:安迪的第一个字典

安迪的第一个字典(Andy's First Dictionary, UVa 10815)


前言:好好学习,天天向上。

问题:
输入一个文本,找出所有不同的字典(连续的字母序列),按字母序从小到大输出,单词不区分大小写。

样例输入:
Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

样例输出:(省略一部分)
a
adventures
blondes
came
disneyland
fork
going
home

 
 
附上代码:
//P112   8.6
//安迪的第一个字典
#include <iostream>
#include <string>
#include <set>
#include <sstream>

using namespace std;

set <string> dict;    //string集合

int main()
{
	string s, buf;
	while(cin >> s){
		for(int i = 0; i < s.length(); i++){
			if(isalpha(s[i]))
				s[i] = tolower(s[i]);
			else
				s[i] = ' ';
		}
		stringstream ss(s);
		while(ss >> buf)
			dict.insert(buf);
	}

	for(set<string>::iterator it = dict.begin(); it != dict.end(); ++it)
		cout<< *it<<endl;

	return 0;
}


发现一篇介绍string和stringstream的博文,大家可以看看。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值