PAT --- 1001.A+B Format (20 分)

1001 A+B Format (20 分)

Calculate a+ba + ba+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers aaa and bbb where −106≤a,b≤106-10^6 \le a, b \le 10^6106a,b106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of aaa and bbb in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题意

计算两个数之和,将两数和按照每3个字符之间输出一个“,”的格式输出。

思路

  1. 将和转成字符串。
  2. 如果当前位的下标i满⾜足(i + 1) % 3 == len % 3并且i不不是最后⼀一位,就在逐位输出的时候在该位输出后的后⾯面加上⼀一个逗号~

代码

#include <iostream>
#include <string>
using namespace std;

int main() {
	int a, b;
	cin >> a >> b;
	int sum = a + b;
	string s = to_string(sum);
	for (int i = 0; i < s.length(); i++) {
		cout << s[i];
		if (s[i] == '-')	continue;
		if ((i + 1) % 3 == s.length() % 3 && i != s.length() - 1)
			cout << ",";
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值