ACM-ICPC 2018 徐州赛区网络预赛-J:Maze Designer(最大生成树+LCA)

After the long vacation, the maze designer master has to do his job. A tour company gives him a map which is a rectangle. The map consists of N×M N × M little squares. That is to say, the height of the rectangle is N N and the width of the rectangle is M. The master knows exactly how the maze is going to use. The tour company will put a couple in two different squares in the maze and make them seek each other. Of course,the master will not make them find each other easily. The only thing the master does is building some wall between some little squares. He knows in that way, wherever the couple is put, there is only one path between them. It is not a difficult thing for him, but he is a considerate man. He also knows that the cost of building every wall between two adjacent squares is different(Nobody knows the reason). As a result, he designs the maze to make the tour company spend the least money to build it.

Now, here’s your part. The tour company knows you’re the apprentice of the master, so they give you a task. you’re given Q Q qustions which contain the information of where the couple will be put. You need to figure out the length of the shortest path between them.

However,the master doesn’t tell you how he designs the maze, but he believes that you, the best student of himself, know the way. So he goes on vacation again.

Input
The first line of the input contains two integers N and M M (1N,M500), giving the number of rows and columns of the maze.

The next N×M N × M lines of the input give the information of every little square in the maze, and their coordinates are in order of (1,1),(1,2)(1,M),(2,1),(2,2),,(2,M),,(N,M). ( 1 , 1 ) , ( 1 , 2 ) ⋯ ⋯ ( 1 , M ) , ( 2 , 1 ) , ( 2 , 2 ) , ⋯ ⋯ , ( 2 , M ) , ⋯ ⋯ , ( N , M ) .

Each line contains two characters D D and R and two integers a,b(0a,b2000000000) a , b ( 0 ≤ a , b ≤ 2000000000 ) , a a is the cost of building the wall between it and its lower adjacent square, and b is the cost of building the wall between it and its right adjacent square. If the side is boundary, the lacking path will be replaced with X X 0.

The next line contains an integer Q Q (1Q100000), which represents the number of questions.

The next Q Q lines gives four integers,x1,y1,x2,y2(1x1,x2N,1y1,y2M), which represent two squares and their coordinate are (x1,y1) ( x 1 , y 1 ) and (x2,y2) ( x 2 , y 2 ) .

(x,y) ( x , y ) means row x x and column y.

It is guaranteed that there is only one kind of maze.

Output
For each question, output one line with one integer which represents the length of the shortest path between two given squares.

样例输入
3 3
D 1 R 9
D 7 R 8
D 4 X 0
D 2 R 6
D 12 R 5
D 3 X 0
X 0 R 10
X 0 R 11
X 0 X 0
3
1 1 3 3
1 2 3 2
2 2 3 1
样例输出
4
2
2

思路:因为要求所有格点连通且任意2点之间只有一条路径,那么这些点应该构成一棵树,把围墙花费当成边权,然后求出最大生成树。

求出树的结构后,询问就是求树上任意2点间的最短路径了,用LCA即可。

#include<bits/stdc++.h>
using namespace std;
const int MAX=5e5+10;
const int MOD=1e9+7;
const double PI=acos(-1.0);
typedef long long ll;
struct lenka{int x,y,z;}ed[MAX];
int cmp(const lenka& A,const lenka& B){return A.z>B.z;}
int p[MAX];
int f(int x){return p[x]==x?x:p[x]=f(p[x]);}
vector<int>e[MAX];
int nex[MAX][21],d[MAX];
void dfs(int k,int fa,int dep)
{
    d[k]=dep;
    nex[k][0]=fa;
    for(int i=1;i<=20;i++)nex[k][i]=nex[nex[k][i-1]][i-1];
    for(int i=0;i<e[k].size();i++)
    {
        int nex=e[k][i];
        if(nex==fa)continue;
        dfs(nex,k,dep+1);
    }
}
int LCA(int x,int y)
{
    if(x==y)return x;
    if(d[x]>d[y])swap(x,y);
    for(int i=20;i>=0;i--)
    {
        if(d[x]<d[y]&&d[nex[y][i]]>=d[x])y=nex[y][i];
    }
    for(int i=20;i>=0;i--)
    {
        if(nex[x][i]!=nex[y][i])
        {
            x=nex[x][i];
            y=nex[y][i];
        }
    }
    if(x!=y)return nex[x][0];
    return x;
}
int main()
{
    int n,m,tot=0;
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            char op[3];
            int x;
            scanf("%s%d",op,&x);
            if(op[0]=='D')
            {
                ed[++tot].x=(i-1)*m+j;
                ed[tot].y=i*m+j;
                ed[tot].z=x;
            }
            scanf("%s%d",op,&x);
            if(op[0]=='R')
            {
                ed[++tot].x=(i-1)*m+j;
                ed[tot].y=(i-1)*m+j+1;
                ed[tot].z=x;
            }
        }
    }
    sort(ed+1,ed+tot+1,cmp);
    for(int i=1;i<=n*m;i++)p[i]=i;
    for(int i=1;i<=tot;i++)
    {
        int fx=f(ed[i].x);
        int fy=f(ed[i].y);
        if(fx==fy)continue;
        p[fx]=fy;
        e[ed[i].x].push_back(ed[i].y);
        e[ed[i].y].push_back(ed[i].x);
    }
    dfs(1,0,1);
    int QWQ;
    cin>>QWQ;
    while(QWQ--)
    {
        int x1,y1,x2,y2;
        scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
        x1=(x1-1)*m+y1;
        x2=(x2-1)*m+y2;
        int lca=LCA(x1,x2);
        printf("%d\n",d[x1]+d[x2]-2*d[lca]);
    }
    return 0;
}
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值