【HD 5053】the Sum of Cube

32 篇文章 0 订阅

the Sum of Cube

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2459 Accepted Submission(s): 1032

Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.

Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.

Sample Input
2
1 3
2 5

Sample Output
Case #1: 36
Case #2: 224

Source
2014 ACM/ICPC Asia Regional Shanghai Online

——————————————————————————————
超级水的一道题
本来要用下面的方法图解的,但是直接暴力出来了……

4   4   4   4   4   4   4    4    4    4     
4   4   4   4   4   4   4    4    4    4  
4   4   4   4   4   4   4    4    4    4   
4   4   4   4   4   4   4    4    4    4           
3   3   3   3   3   3   4    4    4    4 
3   3   3   3   3   3   4    4    4    4 
3   3   3   3   3   3   4    4    4    4 
2   2   2   3   3   3   4    4    4    4 
2   2   2   3   3   3   4    4    4    4 
1   2   2   3   3   3   4    4    4    4
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
__int64 a[10005];
void vo()
{
    __int64 i;
    for( i=1; i<10005; i++)
    {
        a[i]=i*i*i;
    }
}
int main()
{
    vo();
    __int64 j,sum;
    int t,x,y,k=1;
    scanf("%d",&t);
    while( t-- )
    {
        sum=0;
        scanf("%d%d",&x,&y);
        for( j=x; j<=y; j++ )
        {
            sum=a[j]+sum;
        }
        printf("Case #%d: %I64d\n",k,sum);
        k++;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值