POJ 2752 Seek the Name, Seek the Fame

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:输出前缀和后缀中相同序列长度.

如: 前缀有 a,ab,abc…..,ababcababababcabab 后缀有:b,ab,bab,abab,….. ababcababababcabab
前缀和后缀相同的就有ababcababababcabab 长度就为18 ,以此规律就可以推出题意.

这道题很明显是KMP的模板题,我在next数组里面发现了另外一个新规律,目前在网上的博客中为找到与我相同的想法.

AC时间:65毫秒。网上代码一般一百多毫秒。

思路:开一个buffer数组。用于存中途记录的长度。然后倒叙输出就可以了。

既然明白题意就可以贴代码了。这差不多也算是next数组的应用吧。next很神奇。革命仍需努力.

//ACM暑期集训

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int Max=400005;
int nextt[Max];
char str[Max];
void Next(int len){
    int i=-1,j=0;
    nextt[0]=i;
    while(j<len){
        if(i==-1||str[i]==str[j]){
            ++i,++j;
            nextt[j]=i;
        }else{
            i=nextt[i];
        }
    }
}
void Kmp(int len){
   int i=len,index=0;
   int buffer[Max];
   while(nextt[i]!=-1){//模拟这里几遍应该就会了。小伙子别心急。A题不是目的
        buffer[index++]=i;
        i=nextt[i];
   }
   index--;
   for(int j=index;j>=1;j--)
        printf("%d ",buffer[j]);
   printf("%d\n",buffer[0]);
}
int main(){
    while(~scanf("%s",str)){
        int len=strlen(str);
        Next(len);
        Kmp(len);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值