Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers aand b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
#include <iostream>
#include <stdlib.h>
#include <vector>
using namespace std;
vector<int> v;
void print(int n)
{
int tmp;
if (n < 0)
{
n = -n;
cout << "-";
}
else if (n == 0)
{
cout << "0" << endl;
return;
}
while (n > 0)
{
tmp = n % 10;
n /= 10;
v.push_back(tmp);
}
tmp = v.size() - 1;
while (tmp >= 0)
{
cout << v[tmp];
if (tmp % 3 == 0 && tmp != 0)
{
cout << ",";
}
tmp--;
}
cout << endl;
}
int main()
{
int a, b;
cin >> a >> b;
print(a + b);
return 0;
}