PAT (Advanced Level) 1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers aand b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

#include <iostream>
#include <stdlib.h>
#include <vector>
using namespace std;
vector<int> v;
void print(int n)
{
	int tmp;
	if (n < 0)
	{
		n = -n;
		cout << "-";
	}
	else if (n == 0)
	{
		cout << "0" << endl;
		return;
	}
	while (n > 0)
	{
		tmp = n % 10;
		n /= 10;
		v.push_back(tmp);
	}
	tmp = v.size() - 1;
	while (tmp >= 0)
	{
		cout << v[tmp];
		if (tmp % 3 == 0 && tmp != 0)
		{
			cout << ",";
		}
		tmp--;
	}
	cout << endl;
}
int main()
{
	int a, b;
	cin >> a >> b;
	print(a + b);

	return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值