L2-005 集合相似度

L2-005 集合相似度 (25 分)

给定两个整数集合,它们的相似度定义为:Nc/Nt×100%。其中Nc是两个集合都有的不相等整数的个数,Nt是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。

输入格式:

输入第一行给出一个正整数N(≤50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(≤104),是集合中元素的个数;然后跟M个[0,109]区间内的整数。

之后一行给出一个正整数K(≤2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。

输出格式:

对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。

输入样例:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

输出样例:

50.00%
33.33%

思路

每个集合都用set存,要求两个集合的相似度的时候,先找两个集合中相同的数Nc,则Nt就等于两个集合的总个数减去Nc。

AC代码

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <set>
#include <vector>
using namespace std;
const int maxn = 100010; 

set<int> s[55];
set<int>::iterator it;

int main() {
    // freopen("in.txt", "r",stdin);
    // freopen("out.txt", "w", stdout);
    int n, k, x, y;
    scanf("%d", &n);
    for(int i = 1; i <= n; i++) {
        scanf("%d", &k);
        while(k--) {
            scanf("%d", &x);
            s[i].insert(x);
        }
    }
    scanf("%d", &k);
    while(k--) {
        scanf("%d%d", &x, &y);
        double ans, ans1 = 0, ans2 = 0;
        for(it = s[x].begin(); it != s[x].end(); it++) {
            if(s[y].find(*it) != s[y].end()) {
                ans1++;
            }
        }
        ans2 = s[x].size() + s[y].size() - ans1;
        ans = ans1 / ans2;
        ans *= 100;
        // printf("ans1 %f ans2 %f\n", ans1, ans2);
        printf("%.2f%\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值