学生信息输入输出 (10 分)

学生信息输入输出 (10 分)

根据给出的基类,定义派生类,完成学生信息的输入输出(参见输入输出样例)

基类定义:

 

#include <iostream> #include <string> using namespace std; class Student {public: void get_value() {cin>>num>>name>>sex;} void display( ) {cout<<"num: "<<num<<endl; cout<<"name: "<<name<<endl; cout<<"sex: "<<sex<<endl;} private : int num; string name; char sex; }; /*在这里添加派生类的定义*/

测试程序样例:

 

int main() {Student1 stud1; stud1.get_value(); stud1.get_value_1(); stud1.display(); stud1.display_1(); return 0; }

输入样例:

1002 Lisi F
20 beijing

输出样例:

num: 1002
name: Lisi
sex: F
age: 20
address: beijing
#include <iostream>
#include <string>
using namespace std;
class Student
{
public:
    void get_value()
    {
        cin >> num >> name >> sex;
    }
    void display()
    {
        cout << "num: " << num << endl;
        cout << "name: " << name << endl;
        cout << "sex: " << sex << endl;
    }
private:
    int num;
    string name;
    char sex;
};
class Student1 : public Student
{
protected:
    int age;
    string address;
public:
    void get_value_1()
    {
        cin >> age >> address;
    }
    void display_1()
    {
        cout << "age: " << age << endl;
        cout << "address: " << address << endl;
    }
};
int main()
{
    Student1 stud1;
    stud1.get_value();
    stud1.get_value_1();
    stud1.display();
    stud1.display_1();
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值