1237-简单计算器【浙大计算机研究生复试上机考试-2006年】

Problem Description:

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input:

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input:

1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output:

3.00
13.36

题解:

#include<bits/stdc++.h>
using namespace std;
map<char, int> mp;
stack<double> num;
stack<char> ope;

double strToDou(string s) {
    stringstream ss;
    ss<<s;
    double n;
    ss>>n;
    return n;
}

void process(char tmp) {
    while(!ope.empty() && mp[ope.top()]>=mp[tmp]) {
        double a2 = num.top();
        num.pop();
        double a1 = num.top();
        num.pop();
        char op = ope.top();
        ope.pop();
        double ans = 0;
        if(op=='+') {
            ans = a1+a2;
        }
        if(op=='-') {
            ans = a1-a2;
        }
        if(op=='*') {
            ans = a1*a2;
        }
        if(op=='/') {
            ans = a1/a2;
        }
        num.push(ans);
    }

    if(tmp!='!') {
        ope.push(tmp);
    }
}

int main() {

    mp['+'] = 1;
    mp['-'] = 1;
    mp['*'] = 2;
    mp['/'] = 2;

    string s;
    getline(cin, s);
    while(s.compare("0")) {
        //初始化,清空操作数栈和运算符栈
        while(!num.empty()) {
            num.pop();
        }
        while(!ope.empty()) {
            ope.pop();
        }
        //遍历输入字符串
        while(s.find(" ")!=-1) {
            string tmp = s.substr(0, s.find(" "));
            s = s.substr(s.find(" ")+1);
            if(tmp.at(0)=='+' || tmp.at(0)=='-' || tmp.at(0)=='*' || tmp.at(0)=='/') {
                if(ope.empty() || mp[ope.top()]<mp[tmp.at(0)]) {
                    ope.push(tmp.at(0));
                } else {
                    process(tmp.at(0));
                }
            } else {
                double n = strToDou(tmp);
                num.push(n);
            }
        }
        //把最后一个运算数放入栈中
        double last = strToDou(s);
        num.push(last);
        //处理最后一个表达式直到结束
        if(ope.size()) {
            process('!');
        }
        printf("%.2lf\n", num.top());

        getline(cin, s);
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值