PAT 1015 德才论 (25分) C语言实现

1015 德才论 (25分)

宋代史学家司马光在《资治通鉴》中有一段著名的“德才论”:“是故才德全尽谓之圣人,才德兼亡谓之愚人,德胜才谓之君子,才胜德谓之小人。凡取人之术,苟不得圣人,君子而与之,与其得小人,不若得愚人。”

现给出一批考生的德才分数,请根据司马光的理论给出录取排名。

输入格式:

输入第一行给出 3 个正整数,分别为:N(≤10
​5
​​ ),即考生总数;L(≥60),为录取最低分数线,即德分和才分均不低于 L 的考生才有资格被考虑录取;H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于 H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线 L 的考生也按总分排序,但排在第三类考生之后。

随后 N 行,每行给出一位考生的信息,包括:准考证号 德分 才分,其中准考证号为 8 位整数,德才分为区间 [0, 100] 内的整数。数字间以空格分隔。

输出格式:

输出第一行首先给出达到最低分数线的考生人数 M,随后 M 行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。

输入样例:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

输出样例:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

代码:

1.代码地址 https://github.com/MrHaddis/PAT1015
2.代码还有点问题,提示段错误 猜测是因为栈的问题,数组太大了,不能容纳这么多数据导致的,目前还没有想到好的解决方案,先放放吧,回头再填这个坑。

#include <stdio.h>
//MrHaddis
//https://github.com/MrHaddis/PAT1015

struct Student {
    char num[9];
    int deAchievement;
    int caiAchievement;
    int totalAchievement;
};

void sortArray(int index, struct Student studentArray[]);

void printResult(int index, struct Student studentArray[]);

int main() {
    //总的学生
    int totalNumber;
    //低分 高分
    int low, high;
    scanf("%d%d%d", &totalNumber, &low, &high);
    if (totalNumber > 100000 || low < 60 || low > high || high > 100) {
        return 0;
    }
    struct Student studentArray[totalNumber];
    struct Student studentArrayFirst[totalNumber];
    struct Student studentArraySecond[totalNumber];
    struct Student studentArrayThird[totalNumber];
    struct Student studentArrayFourth[totalNumber];
    int indexFirst = 0;
    int indexSecond = 0;
    int indexThird = 0;
    int indexFourth = 0;
    for (int i = 0; i < totalNumber; i++) {
        scanf("%s %d %d", &studentArray[i].num, &studentArray[i].deAchievement,
              &studentArray[i].caiAchievement);
        studentArray[i].totalAchievement =
                studentArray[i].deAchievement + studentArray[i].caiAchievement;
        if (studentArray[i].deAchievement >= high && studentArray[i].caiAchievement >= high) {
            studentArrayFirst[indexFirst++] = studentArray[i];
        } else if (studentArray[i].deAchievement >= high && studentArray[i].caiAchievement >= low) {
            studentArraySecond[indexSecond++] = studentArray[i];
        } else if (studentArray[i].deAchievement < high && studentArray[i].caiAchievement < high
                   && studentArray[i].deAchievement >= low && studentArray[i].caiAchievement >= low
                   && studentArray[i].deAchievement >= studentArray[i].caiAchievement) {
            studentArrayThird[indexThird++] = studentArray[i];
        } else if (studentArray[i].deAchievement >= low && studentArray[i].caiAchievement >= low) {
            studentArrayFourth[indexFourth++] = studentArray[i];
        }
    }
    printf("%d\n", indexFirst + indexSecond + indexThird + indexFourth);
    //一个简单的冒泡排序
    if (indexFirst > 0) {
        sortArray(indexFirst, studentArrayFirst);
    }
    if (indexSecond > 0) {
        sortArray(indexSecond, studentArraySecond);
    }
    if (indexThird > 0) {
        sortArray(indexThird, studentArrayThird);
    }
    if (indexFourth > 0) {
        sortArray(indexFourth, studentArrayFourth);
    }
    return 0;
}

void sortArray(int index, struct Student studentArray[]) {
    int len = index - 1;
    for (int i = 0; i < index; i++) {
        //设置一个标志位
        int flag = 1;
        int tempPostion = 0;  // 记录最后一次交换的位置
        //先给数组排序从大到小
        //然后如果不是1的 则为关键字
        //这时候需要输出
        for (int j = 0; j < len; j++) {
            if (studentArray[j].totalAchievement < studentArray[j + 1].totalAchievement) {
                struct Student temp = studentArray[j];
                studentArray[j] = studentArray[j + 1];
                studentArray[j + 1] = temp;
                //发生交换,标志位置0
                flag = 0;
                tempPostion = j;  //记录交换的位置
            } else if (studentArray[j].totalAchievement ==
                       studentArray[j + 1].totalAchievement) {
                //    当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。
                if (studentArray[j].deAchievement < studentArray[j + 1].deAchievement) {
                    struct Student temp = studentArray[j];
                    studentArray[j] = studentArray[j + 1];
                    studentArray[j + 1] = temp;
                    //发生交换,标志位置0
                    flag = 0;
                    tempPostion = j;  //记录交换的位置
                } else if (studentArray[j].deAchievement ==
                           studentArray[j + 1].deAchievement) {
                    //这里对学号做比较
                    for (int k = 0; k < 8; ++k) {
                        if (studentArray[j].num[k] < studentArray[j + 1].num[k]) {
                            struct Student temp = studentArray[j];
                            studentArray[j] = studentArray[j + 1];
                            studentArray[j + 1] = temp;
                            //发生交换,标志位置0
                            flag = 0;
                            tempPostion = j;  //记录交换的位置
                        }
                    }
                }
            }
        }
        len = tempPostion;
        if (flag) {
            //如果没有交换过元素,则已经有序
            break;
        }
    }
    printResult(index, studentArray);
}

void printResult(int index, struct Student studentArray[]) {
    for (int j = 0; j < index; j++) {
        printf("%s %d %d\n", studentArray[j].num, studentArray[j].deAchievement,
               studentArray[j].caiAchievement);
    }
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值